Nav bar always appears on interface launch


#1

The navigation bar appears almost every time I launch interface. I suspect what is going on is that the domain I am arriving in takes several seconds to communicate and perhaps that delay triggers the nav bar to pop up?

Quite annoying.


#2

Scratch head, so it’s not me that hit by accident enter.
It not happens always for me, but sometimes i where puzzled how the goto got open.

Mabye i pressed enter (buffer) mabye it’s the same problem you see but less worse.
Most times it not happen. only in HMD i have mabye seen it more.

5312 is for me anyway pretty screwed. lot’s of weird things happen. problem is the came and go.


#3

I do find 5312 much better on rendering speed and consistency, but yes, there are a number of broken bits throughout. I was careful in my tests to stay away from the keyboard. Mouse launched interface. And BTW, as I launch and quit interface several times during these tests, I got interface to crash on launch. So yes, instabilities.


#4

This seems to happen when launching interface where the domain it tries to connect to is one handled by UDP punch-through and that domain has not been visited for a while.

I have verified that the nav bar is opened by interface on launch after a few seconds when it finds the domain is not connected. As an example I used the blacksun place name as that domain is not connected presently. In my original case it was both of my domains, place names spiritmoving and conference. Both of mine use UDP punch-through, and initially it takes almost ten seconds to connect. Thereafter they connect almost immediately. I think the show-nav-bar timeout is too short. It needs to be longer than the time for UDP identified domains to connect.


#5

I can confirm that i get the same , but i also think why !
The goto window appears when you login on domain that is “disconnected” in this case my localhost where offline. the goto nav appeared.

When i do the saem on my simsquare domain nothing seems to happen and the nav screen keeps away. Mabye it’s having 2 purposes. A: help new users to get out of that place. and B: it tells you the domain is offline. But that is just a guess.


#6

… it appears to be on a 5s fuse and as speculated is essentially triggered by the absence of domain connectivity.

This feature was driving me a little bonkers last week – so in my local build I toyed with an .ini option to disable it:

Not entirely sure that’s the best way to go, but maybe something like the above could be proposed back as PR.


#7

looks like austin did a fix for this that just got merged, if you want to try the latest dev-download

https://github.com/highfidelity/hifi/pull/8557


#8

In beta 20, this bug still exists. It happens many times that the goto screen appears on valid and running domain.

I think the goto window need to wait longer before it decide to appear. It’s for sure not fixt and start to get annoying.

I preffer to turn the option of on my system, but how ? There;'s no setting for that i think.