New domain-server settings


#1

A new domain-server settings page is now live. When your stack manager updates your domain-server, this is what you will see if you visit the web interface for your domain-server and then go to the ‘Settings’ tab.

For those of you who have restricted access to your domain-server, you will need to redo that HTTP username/password configuration in this settings page. Once you hit ‘Save and restart’ you will immediately be prompted for that username and password to access your domain-server.

For those of you who have set your domain ID in your resources/config.json, you will need to put that ID on this page and then hit ‘Save and restart’. This is what connects your domain-server to a domain in the High Fidelity metaverse, and allows users to create locations in your domain and jump to them.

For now the ‘Access Token’ is not required - although I am currently adding features that will leverage that token to make domain-server setup even simpler.


#2

@Ai_Austin when your stack manager updates your domain-server you will want to re-set your HTTP username and password this way!


#3

I can add my http username, then http passwd.
after restart only the http username is visible. so not sure if its added or not.


#4

For security reasons that is not displayed again on the page - you’ll only need to re-enter it if you want to change it.


#5

@Ai_Austin @Judas @Adrian make sure you read this post.


#6

@b thanks, its still in the config.json file anyway. in case i forget the password lol, ill change that at later time if its not needed anmore there. It works fine for me.


#7

Got it and settings changed as required for hifi://Vue. The old config.json is left in place, but I manually removed that.

I added a picture to an existing location in the Vue domain, but that has not (yet) shown in https://data.highfidelity.io/directory Will it eventually appear, or will all old locations not work even if a picture is added?

As a test, I also created a new named location on the Vue domain with a snapshot attached. But cannot (yet) see it in https://data.highfidelity.io/directory
Should it not appear immediately or is there a delay?


#8

@Ai_Austin have you also set your domain ID in the settings?


#9

Yes, the domain id was set to the uuid that was allocated for Vue and that previously worked before the domain manager update. The previous lication I added an image to, and a new location created with an image and that reported success in doing that via the interface are still are not showing after 6 hours or so.


#10

What’s the location name? I’ll look into it.


#11

I have just tried it, the first time it failed. but thats because i used a space in the name. My Ok. second time it appears in ‘my locations’ seems image where not uplaoded, edit the link and add image. and now its visible,

@Ai_Austin check if there’s really image uploaded.

Note: can HifI give instructions howto linmk the directoty webpage to hifi ? because the links there dont work. but i expect to get the directory inworld later, then its not needed.
Hmm, cannot edit the settings “We’re sorry, but something went wrong.”


#12

Newly created location with image was vuehome in domain Vue. But via web interface it does not show an image, and an attempt just now to upload an image to it via web interface seems to hang. Is issue that the image upload is failing via interface and via web interface perhaps?

Seems to hang about a third of way in when uploading an image via web interface… may be same issue via the HiFi interface program.


#13

I have uploaded the image straight from my webbrowser. because inworld i could not upload the image. But internet seems a biut wacky today everywhere to. I cannot edit anymore the domain location settings.


#14

@b I managed to upload a location image on the web interface via web interface on Internet Explorer on Windows. On Safari on iPad it locked up each of about 10 attempts. The in world Interface attempt to add an image also failed on creating a new location, though the location was created… just the image selected (an in world snap shot put on desktop locally) was not uploaded.

So I have 4 location showing now in Vue domain.


#15

@b, today, I cannot use the edit facility on the “My Locations” table at

https://data.highfidelity.io/locations

I get “We’re sorry, but something went wrong” popup box every time. It worked fine yesterday (on Windows 8.1 Internet Explorer).


#16

Awesome we now got a directory.


#17

@Ai_Austin which location was giving you the error on edit? I’ll see if I can track down what is going on.


#18

It is every one of my locations which have an image attached when I enter https://data.highfidelity.io/locations after logging in. So in theVue domain aiai, vuehome, supercar and iss all fail

On both Windows 8.1 and Windows 7 and with Internet Explorer and Firefox latest versions.

I get this message when I use the “pencil” edit icon…

We’re sorry, but something went wrong.
If you are the application owner check the logs for more information.

It WORKS if no image has been attached to the location.


#19

Just treied it again, still cannot edit soem of my lcoations.

We're sorry, but something went wrong.
If you are the application owner check the logs for more information.

Others i made i can edit.


#20

@Ai_Austin @Richardus - should be fixed now!