New entities screen


#1

It looks really great !.
But one bad habbit that is taken from windows 10. The very small scrollbar and hard to grab.

The scrollbar is really small, double the width would be much better.
The text can be lighter to, more in the direction of white. Bad contrast now, edge case.

A few more screenshot.


#2

@Richardus.Raymaker Are you on Windows or OSX? And what OS version? The fonts on your screen aren’t right (should be sans-serif and the big "M"s should be little icons)?


#3

Windows 10 Pro - 125dpi setting.
Testing this with Entity, mabye that explains the M ?

Also why is Refresh now changed into a button that is named F ?


#4

Yes, the “F” is meant to be a “refresh” icon … for some reason, fonts aren’t being picked up properly on your PC.
I haven’t actually checked the official build yet 'cos it only came out just as the meeting was starting. I’ll check straight away after.


#5

This is what the grid tab, for example, should like …

@Richardus.Raymaker Where are you running the edit.js script from?


#6

It’s downloaded from amazon S3,

if correct sofar i see am still using the default scripts. That is why i do not change or mess with scripts. it’s not the good development stage for it.


#7

@Richardus.Raymaker Thanks! I’ve reproduced: there are some font files missing from S3. … Am looking into it.

Running scripts from local install, which is what the Settings > General… > Load Default Scripts button now does, finds the font files OK. (As I understand it, scripts by default are run from the local install because often changes to Interface and scripts need to be kept in sync to work properly.)


#8

Intressting. that would mean interface never updated the location where the scripts are loaded from. defaultsacript not get replaced on my system so it points to local scripts ?

Need to look in it other time if needed.


#9

I’d say that your installs left just your current settings alone; new users’ installs will default to running defaultScripts.js locally.


#10

Switched to local defaultscript now. Did not know it where changed. That where btw not easy task todo.

Other problem i see, the path in preference is set to a strange location.

That font looks much better now ! :slight_smile:

Just tested something else , and found a small things. There is not enough space between the up/down arrow and the rotation. this must be caused because the minus get add automatic.


#11

Desktop as default location for “load scripts from this directory”: I believe that this is intentional. Perhaps it should be a user’s “Documents” directory, though?

Rotation values: It looks to me like there are too many decimal places, too! A ten-thousandth of a degree is probably not a usable value? … Good point re the negative though: I need to tweak the position fields to accommodate large negative values. Thanks!


#12

It is vitally important to have accuracy to 4 decimal points, you would be amazed how 0.0001 can cause a huge discrepancy to a 100m long entity.


#13

Good question, i found defaultscripts.js in the high fidelity program directory under the scripts folder and pointed to that one. because that seems to get updated always for my feeling.


#14

@Balpien.Hammerer Thanks very much for the 4dp needed for rotations; I’ll adjust the field formatting to fit