New transparent/translucent issues


#1

As I had mentioned on github, 4519 has broken much of my transparent/translucent stuff:

All my windows made from simple textures and all my tree silhouettes are now broken. Oh well…


#2

Some how, I managed to replicated an old bug when attempting to put layered alphas on my avatar.
4540:

On Build 4546 tha alphas are not taken at all from the textures though, so cant replicate.

@Twa_Hinkle said that he can see the layers.

@Chris


#3

Menthol’s tail close up.


#4


#5

I had to increase tightness of the alpha, and then it started appearing. Interestingly this didnt work on @DrFran 's mac. So I guess gradiental Alpha doesnt work for avatars yet?


#6

BUMP.
Not sure if this was the same issue, but alpha textures havent been transparent for a few days.

This is still a problem at 4563.
Look at this tree.


#7

I see only the alpha problem on my mixamo avatar.
My snappytree looked fine yesterday. Ill check it later today again.

My tree’s still look fine. is the one you use alpha in blender ?

Instead my mixamo fuse avatar is still broken with alpha.


#8

I have fixed all my texture alpha channel problems that I posted about above by taking the original model into Blender and changing the diffuse (albedo) texture influence to include the alpha channel as shown here:

It is a pain but for the most part, you only have to do it once for each texture with an alpha component in each model that has one. Then just reexport the fbx, upload to HiFi and paste the new fbx file URL into the model URL field in entity properties.

One thing though, I always use unique file names like “cat-07a”, “cat-07b” etc. just so I don’t have to worry about various layers of cache that exist between amazon s3, the net in general, and HiFi etc.

Fran has had some issues with this on her MAC but has managed to eventually get most transparent/translucent things working. She has a different work flow than I use so it is sometimes hard to pinpoint what the problem is.


#9

Thanks for the suggestion @Twa_Hinkle Im glad that works for you.

However I am not content with redoing all my work again, I think this feature is broken and should be fixed.
Unless a developed comes in and tells me directly that something has changed and this is the way it is now, in which case I will live with the truth as usual and do the workaround.

I have in the past spent hours and hours fitting out a workaround only to have the bug fixed and all my extra work trashed and have to redo it a third time.

If it takes some time to fix this bug thats ok, I know there are priorities, but I think it is a bug and I will keep posting until its fixed or someone confirms otherwise. @chris can you please get an official answer either way? Thanks.

EDIT:
It occurs to me that this could be due to the new PBR shader system, the alpha component is now part of the influence?
If this is the case, ok, just say so and I can get on with the job of bringing my textures up to date. Cheers.


#10

I still think it’s a bug, that need to be fixt.
Or ismixamo fuse not using standards ?

Wich standard is used ? FBX, Blender. or a cutom mixed one. You would think it’s the last one if it’s not a bug.

Besides, my avatar i cannnot fix becuse it’s rigged and blender sounds a bad combination to try atm.


#11

It is just FBX, with HumanIK Skeleton Standards but High Fidelity Material Definitions.

Confusion comes from the fact transparency is currently quite sensitive to the many PNG variations, and behaviour is different for both gradiental and mask based transparencies.

Known issues with Blender is
A. Animation playback
B. Oddities with Embedded textures which I havent gotten around to documenting.
C. Oddities with UV Maps which I havent yet been able to replicated (ill try to look into your door again later, I think I may know the issue actually now that I have had time to think about it)

Issues related in General to all suites( even if blender or maya or mixamo)
A. PNG Type for Transparencies
B. Murkyness of How to switch between a Mask and a Gradient Transparency
C. Avatar Transparencies not working similarly to Entities: Only seems to work if transparency is fully binary
D. Mirrored/Flipped UV causes normals to have issues


#12

I did the alpha influence thing and it fixed one item for about a day, even the fixed one is now opaque.

@chris can we get word on this please, is it a bug? or is it expected behaviour?


#13

It’s time this bug get fixed. Just checked the mixamo avatar texture. and it’s really alpha. But it’s showing black in high fidelity. And it’s not fixable in blender. Because it’s UV-Map texture.

Tried TGA, it seems to have no change at all in high fidelity. Already suprissed that just export the avatar where enough. it seems to walk and work. Or… The stupid cache is interfering again.

Not much difference with TGA texture.

Note autodesk FBX viewer is shoing it not alpha too. But that viewer i do not trust with textures. It’s doing more weird incorrect things.

I need CC0 high fidelity skeleton to test something else , when i want.


#14

Skeleton is already CC0ed @ Standard

TGA doesnt work, the transparency uses PNG alpha. For avatars this transparency is binary, not gradiental, so you have to make sure that the alpha layer only consists of black or white. if it is gradiental, everything is considered solid.


#15

Intressting…

This is how blender is showing it, i woul;d say that is 100% alpha.

Checked it in paint shop pro, it’s 100% alpha. other viewer are showing the alpha as white or black.


#16

Sorry to necro this old thread and I know it’s probably not the right place for this, but I couldn’t find any way to directly contact ya but, recently I’ve tried to get my own custom model working in Hifi and while successful, I couldn’t really get the texture on one part of it how I’d wanted.

So, in secondlife, I got the alpha setting set to Alpha Mask, and so looks like this

But in Hifi, all the different settings I could think of to change, it just keeps coming out looking like this


Basically, if that was in SL, that would be the default alpha setting named “Alpha Blend”

So, I noticed in one of the replies here, someone posted a close up of a tail on that avatar of yours and it looks like it’s the alpha effect I’ve been trying to get it to.


So, long story short, how did you manage to get the alpha to do that, and is it still possible?


#17

Unfortunately its been a year so things may be a bit fuzzy (pardon the pun) and may have changed but here his the main details:

High Fidelity used to support only single type of transparency for avatars, which is the masked transparency alpha: but since then avatars also support blended alphas. This specific thread was due to them not working at all on the Mac (so this should be closed and a separate thread line created instead! Go throw a hello to the Welcome thread and then post a new thread.)

Forexample here is my “Furball” test avatar you can use as reference. This is a Non-Masked (Blended)

https://s3.eu-west-2.amazonaws.com/norteclabs.com/HF/experiment/furavatar/avatarFurTest.fst

Then here is a Masked example

https://s3.eu-west-2.amazonaws.com/norteclabs.com/HF/experiment/furavatar/avatarFurTestMasked.fst

There difference in Texture is just the levels of alpha available: The Engine decides which one to use using that info instead of a mask flag.

  • If the texture has many semi Opaque pixels (somewhere betwen solid and non-solid) the texture mode is set to Blend.
  • If the texture has a much larger ratio of only Opaque and fully transparent pixels, the texture mode is set to mask:

So to solve your issue take the alpha layer in your editing software, and adjust the levels so that you only have on / off pixels. If you want to have a mask alpha.

For future reference, and for any one wanting to look at the source code, the logic can be found here and here