NEWS about linux compatibility hardware?


#1

Hi!

I wonder if there are Head Mounted Displays, Hand Controllers or Audio Headsets working with Linux and HiFi.

Thank you,
Jose Manuel


#2

Technically speaking SteamVR Linux should be possible to work ontop of the Interface, but no one here uses them or has developed for it.

Linux clients work too, but you need to compile them by one self.


#3

Found: https://github.com/ValveSoftware/SteamVR-for-Linux/issues/72


#4

Does building the HiFi client for Linux work with Ubuntu 16.04 LTS? The documentation talks about Ubuntu 14.04, which was released in 2014. So clearly the documentation hasn’t been updated in a while.


#5

Should build fine, as long as you get all the dependencies correct which is the part that usually takes the most effort.


#6

I updated the compiling procedure here:


I did a PR:

I tested it one week ago and worked well.


#7

Trying to build on Ubuntu 16.04 LTS using the directions.

The command

cmake -DQT_CMAKE_PREFIX_PATH=/usr/local/Qt5.10.1/5.10/gcc_64/lib/cmake ..

produces the error:

CMake Error at cmake/macros/SetupQt.cmake:65 (message):
  Unable to locate Qt cmake config in /home/john/Qt/5.10.1/gcc_64/lib/cmake

Qt is in /usr/local, where it’s supposed to be, not in the home directory. Why is cmake looking there when it was told to look in the right place?


#8

Found it: Typo in web page.

cmake -DQT_CMAKE_PREFIX_PATH=/usr/local/Qt5.10.1/5.10/gcc_64/lib/cmake ..

should read:

cmake -DQT_CMAKE_PREFIX_PATH=/usr/local/Qt5.10.1/5.10.1/gcc_64/lib/cmake ..


#9

Next error:

==> glad45-configure-err.log <==
CMake Error at CMakeLists.txt:1 (cmake_minimum_required):
  CMake 3.6 or higher is required.  You are running version 3.5.1

Well, yes. That’s what you get with Ubuntu 16.04 LTS, which is what those directions are supposed to be for. Installed CMake 11 from the CMake site and restarted the build.

If you plan on doing this, don’t expect it to work and allow at least half a day for working around bugs in the build process.


#10

OK, so I get the interface built, and after figuring out that it’s in the “build” directory, launch it.
Runs OK. So now I have the New User Experience.

I go to “dev-welcome”, and I see the same grid and empty hangars I saw two years ago. Nobody there. I try the web site to see where to go. They suggest “marketplace”. (Of course). That’s “Avatarisland” (not that the web site makes it easy to figure that out.) Going there yields:

[04/25 18:18:15] [WARNING] [hifi.networking] The domain-server denied a connection request: "Protocol version mismatch - Domain version: 8174"

Now, I just built the viewer from the latest release sources. Why do I have a protocol domain version mismatch?

Tried to go to other recommended places. CODEX:

[04/25 18:22:34] [WARNING] [hifi.networking] The domain-server denied a connection request: "Protocol version mismatch - Domain version: 8108"

RUST: fails, version 8174.
NATIONAL-PARK fails, version 8174
MEXICO fails, version 8174.
FUMBLELAND fails, version 8108.

I can visit a few default places, like Blue. The machinery works, but the destinations are all empty. Am I doing something wrong, or does this thing just suck?


#11

Thinks you built the dev build u don’t get Dev welcome in the regular one.only the elusive Devs use that one


#12

Did you see muy MR?

Go to downloads and look for the release number.
Then in cloned repo
Git fetch -a
Git checkout tags/RELEASE-number

Compile as usual.


#13

In theory today Ubuntu 18.04 will be released today. I tryed to compile HiFi one week ago in an instance with 18.04 and right qt version. It worked like a charm!


#14

Sorry. Downloading web page has changed!

I cannot see the release number in page so I cannot compile the right tag! How can Ubuntu users know what git tag to compile?

In downloading page there is the Ubuntu logo. Does exists any precompiled and official client/domain server/assignment client yet?

Thank you