No edit permissions anymore since beta 14 :(


#1

Installed btea 14, wanted to remove some entitt in HMD mode. No permission todo that.
Double checked it in Desktop mode, no edit button. So in the menu i did open the entities list. I can select items. But not edit !

That’s annoying !

Nothing changed in my permissions it’s still the same and worked before.

I think this fix broke things. So a fix is needed. BTW. why is it not case sensitive, that’s more logic. unless new accounts cannot be created case sensitive anymore. But i like to have uppercase letters.
1. fix domain-server permissions-grid usernames to be case insensitive


Beta release 14 comments
#2

Have you tried logging back into Interface? The new protocol build dropped me. So I had to log back in.

That fixes it.


#3

Right, that’s one problem. But if you select entities list you cannot go to the properties tab. Now i need to find the edit option. But there’s no other edit option in the menu (i disabled for testing ctrlaltdavid script and running the default one)

So i can select entity, but still not move or edit it. and the edit button is gone from my screen since this version in desktop mode. Hmm. inspecting the log file. something is broken or changed in high fidelity.

    [06/28 13:36:40] [WARNING] Could not find tab for file:///<drive>:/Program Files/High Fidelity/scripts/system/html/gridControls.html
    [06/28 13:36:40] [DEBUG] New tab URL: file:///<drive>:/Program Files/High Fidelity/scripts/system/html/gridControls.html
    [06/28 13:36:40] [WARNING] Could not find tab for file:///<drive>:/Program Files/High Fidelity/scripts/system/html/entityProperties.html
    [06/28 13:36:40] [DEBUG] New tab URL: file:///<drive>:/Program Files/High Fidelity/scripts/system/html/entityProperties.html
    [06/28 13:36:40] [DEBUG] Url changed to file:///<drive>:/Program Files/High Fidelity/scripts/system/html/entityProperties.html

Anyway logging in , out and in , restart high fidelity, teleporting to domain and back. Not working. and because i do not have edit button. am not sure if you use “entities list” in the menu disables the edit option

Anyway, never seen the login screen and i think that where not the problem. but something changed in interface.ini what created again some problem.


#4

I wiped my interface.ini now i have the edit button back and i can edit again.

But why is there no edit in the menu ?
Confirmed entities list not let you go to properties.

So when your edit button is gone your complete doomed !


#5

That log in thing just caught me also