No sound at all in 6618 and 6594


#1

Okay, last Friday I installed the then latest HF, went to the meeting at Zaru… and got absolutely no sound whatsoever. Someone there suggested I switch to a different sound playback device and back, so I tried that, but nothing changed wrt to me hearing any sound at all. Mind you, all of the available ones seem to be variations on the same integrated sound device.

I also noticed then that at least 1 or 2 other people had stated they were getting no sound whatsoever, too. I’ve not been on since last Friday, A half hour or so before the meeting today, I updated to the newest HF, which dutifully plopped me down in world at Zaru once the install had finished…

…and I still have no sound whatsoever inside Interface. I had hoped and figured that, since at least one other person had identified there was a malfunction with the sound, that it would have been fixed by now, but apparently it hasn’t.

Attached is a screengrab of my Audio pane in Interface from a week ago. Looking at it in Interface today, it is identical to what I saw a week ago.


No sound in State of VR (build 6658 on osx)
#2

And here is another screengrab from today, with the Audio dropdown showing.


#3

I had trouble getting sound playing today, after installing release build 6618 over top of dev builds. Ended up deleting Interface.json, rebooting, and then ticking and unticking the Audio Output menu item a couple of times. … Don’t know exactly what got it working but it did eventually.


#4

Well, I’ve pretty much always placed the dev builds into a different folder than regular HF builds, but haven’t installed one of the dev builds since we last had an official come-to-the-meeting-using-the-dev-build event. Would there be independent copies of Interface.json in those two respective install folders, or is that something that goes into the Roaming > High Fedelity folder? (Goes and looks.) Okay, I see Interface.json in the Roaming folder, will now quit out of Interface, remove/rename that, and launch it again.

edit: Still no audio, and now I’ve lost the Chat button from the apps bar at the top. And I’m a wooden-stick-figure doll.

edit2: Went to the Audio drop down, unchecked Use Speakers (Realtek High Definition Audio) for Output, recheckmarked it, got a DONG!!! sound …then …still got no audio at all from in world. oO


#5

I had it happen once - and like David - I had to click audio device selection multiple times before it took. It’s very hit and miss so someone who could never get it to select would probably be valuable in helping devs track down issue.


#6

Okay, this is weird, sound didn’t turn back on after checking and unchecking under Audio > Output Audio Device several times, but as soon as I checkboxxed under Audio > Input Audio Device (which was unchecked), suddenly I had audio! What the actual frak?!?!? oO

edit: Okay, went back and restored the previous Interface.json file (and kept the new one under a renamed copy, plus made a backup of the old one too). Same thing happened under that one: checkboxing the INput line in Audio drop down instantly brought back in-world sound. But I also had back all the stuff like the Chat app button that disappeared with the new json file.

Why would turning on Audio > Input Audio Device enable me to hear in-world chat now? Isn’t Input Audio Device strictly where-you-plug-the-microphone stuff? Oo