No Texture on mesh object after bring it inworld. and no log file


#1

Ok, i combined my postings to one,

Ok, i have my first mesh object inworld saved with blender as fbx file. put it on my webspace , used the url. that works all fine. i see the baked colors on the mesh. but the test textures or gone ! What did go wrong ? Also i cannot find any log file to read.

found the log,
not on place you would look. view -> log still want to find it on the hdd.
 But no errors on my mesh, so where are the textures ?

We still need that terrible autodesk fbx converter for blender ?
yes terrible because the font is so tiny, its almost not visible.
anyway with that converter i get some textures on the mesh.
but not the cloud generated one from blender.
Strange because last time i asked fbx worked with blender, but not here.


#4

You no longer need the fbx converter, Blender now supports fbx exports in ascii and binary.
For exporting a simple object (as opposed to an avatar) you export as binary, have you looked at Judas’ video
https://alphas.highfidelity.io/t/blender-texturing-for-models-in-hf/679

Ensure your textures are uploaded along side the models at your webhost.

To get to the log file on your hdd, go view -> Log (as you mentioned) then click the button "Reveal Log File"
that opens the file in your local directory.


#5

@Richardus also can you link to the FBX here so we can take a look.


#6

@chris no problem. only where a bit bad with nameing.

this one must be from blender.
http://assets.sqmv.nl/hifitest.fbx

and this one i have saved as obj like other forum topic say and converted to fbx.
http://assets.sqmv.nl/http://assets.sqmv.nl/hifitest-001.fbx

and in case you want it, the blender file.
http://assets.sqmv.nl/hifitest.blend
http://assets.sqmv.nl/hifitest-001.blend

and the images i used for testing



Hopefully thats enough :slight_smile:
I go look tomorrow at judas movie.


#7

@Richardus

I brought up http://assets.sqmv.nl/hifitest.fbx in a 3d modeling package and it looks like the following:

is that how it is supposed to look?


#8

no. if i choice render in Blender it looks close to this.

The pink clouds are on the back to,
strange thing the images seems rotated inworld on the fbx converted one. but thats for later. Not excludeing that am doing something wrong in blender to, but in sl with dae it works fine, also rotated images, thats posisble blender to uv map problem.

i redid for safety the last step uv-wrapping , bakeing and save as fbx again. here’s the file
http://assets.sqmv.nl/hifitest-dae.fbx suprissly that file shows the images fine, only not the pink clouds.

You can see the object on my domain, its up.


#9

Looked at judas video, seems i need to learn a new workflow for high fidelity.
i do it just a bit different now.

Thanks to @chris and @judas it looks like it works now for me. as long i use images. fixt the rotation to. so i can experiment further now. and no material limit , so thats less headaces.


#11

Why did i have not posted here what i did wrong :open_mouth: Because i have again. mesh without textures. back to judas video, on relaxed hour. To not forget it again.

Path Mode -> Copy -> embed textures