No textures anymore on new ATP uploaded entity. And scale still wrong


#1

Problems…

First one is that i made a new object with textures. FBX viewer is showing the textures. High fidelity is showing nothing ! No textures. just grey object ! :worried:
One of the problems seems that supid , annoying cache again. i just made a test cube. name test.fbx. and just before that i used other file named test.fbx. and it’s still using the old test.fbx when i have deleted that one first from ATP. Ok, i just crashed the viewer when i did press refresh in the entities properties.

Finaly, logged again in, pressed reload in entities list. clicked on the cube. where is it ?
Foun it as a big cube. but still no textures ! Something is broken !

FBX viewer

Other problem is the scale, it’s still appears as tiny entity.many times and the scale is set to 1.0 and metric. when it did go wrong again. or i fixt that setting and still upload appear as tiny entitie first case.


#2

<<<>>> I didn’t realize your textures were embedded.

Sorry about that.


#3

Why ? i use embedded textures in the fbx file. and that works fine on all other objects. Need to check the log.


#4

Ok. grin. Not so far to test external textures. Then it where explainable. So where still in some mystery.

The story get more intressting. i see some textures. But soem are replaced by the wrong one. i Joined somnepart to move it correct. Mabye high fidelity does not like that. Hmm, tried other door. Only see one texture. n the whole object.

Anyway, i have 2 objects 1 joined and one from seperate parts and both fail. No errors in the log btw. It’s getting stranger, the fbx i did send to chris only show one texture now. because to source drive is offline. Importinmg the fbx now is showing a pink object.

This are my FBX export settings i use foir while and worked fine.

@chris, you have the FBX file from one of the 2 failing objects.


#5

I opened the file in another 3d modeling package. There are no textures.


#6

I just figured that out to. Need to double check what’s going wrong because i swear i say put them in the file. Thanks @chris

The textures must be inside there. i see the file size is bigger. but mabye not all textures. This is weird. Why does it look like beldner is not putting all textures indside the fbx ?


#7


check the source location

what I’m finding works best is put all the textures in the same folder as the model and blend files

b4 you load the textures into blender or much like me it gets confused


#8

Yes, i do that for a long time. i do not much different then i did before. Only thing i did is export the door out of the main project and import in in empty project. So i could make different ones. In blender it looks all fine. But with exporting it’s going complete wonky.

1 week ago it all worked fine with my house. It mabye have something to do with the exporter -> import -> save as blend file -> edit -> export again as fbx

But installing blender 2.77 first now.

Anyway, with 2.77 same problem. and FBX viewer is showing one materials now too. A spade would be welcome now. To dig deeper. :slight_smile:


#9

Slaps spade to own head. Stupid… :flushed:

For some reason, with exporting a texture folder where created *.fbm and that is why the textures failed. i did load the textures again into the bledner project by selecting the right one from the correct location, yes the same directory.

Did upload the object again, offcourse a fail but the new refresh button fixt that…
Thanks @chris, @judas.

Now i have only a weird problem that the texture alignment is shifted inside high fidelity and it’s looking correct in blender.