No Textures When Uploading Models Since Update


#1

Textures appear broken with latest model uploading update.

Since the new model importer has been rolled out, when I upload a model, it’s not textured. I’ve even tested by uploading stuff I’ve uploaded before that’s worked, still no textures.

Also, I’ve never been able to upload a model to my domain either… not sure why that is, other’s have with no issues.


#2

@John_Laury what does your view>logs say? Also send me a link to one of the models


#3

I dug the relevant bits out and deleted all the other chatter… this is what it’s saying…

> [2014-08-18T22:39:22] script:print()<< "Reading model file" 
> [2014-08-18T22:39:22] script:print()<< "Model file: C:/Users/John/Desktop/High Fidelity/Models/boxTest2.fbx" 
> [2014-08-18T22:39:22] script:print()<< "Setting model properties" 
> [2014-08-18T22:40:44] script:print()<< "Preparing to send model" 
> [2014-08-18T22:40:44] script:print()<< "Sending model to High Fidelity" 
> [2014-08-18T22:40:46] script:print()<< "Checking uploaded model" 
> [2014-08-18T22:40:52] script:print()<< "Checking uploaded model" 
> [2014-08-18T22:40:57] script:print()<< "Model uploaded: http://public.highfidelity.io/models/content/boxTest2.fst" 
> [2014-08-18T22:41:00] script:print()<< "Model added: http://public.highfidelity.io/models/content/boxTest2.fst" 
> [2014-08-18T22:41:01] "Error downloading http://public.highfidelity.io/models/content/boxTest2/textures/seamless-wood-texture-free-40.jpg - server replied: Not Found" 

The model is uploading fine, but the texture doesn’t seem to go with it. The model itself seems fine because the server is looking for ^^ that texture, which is the proper name. When I exported the model, I have the Blender 2.71 fbx export option set to absolute and “batch own dir” unchecked which was working fine before.

When I uploaded the model, the new dialog window has a button to select the proper folder for the texture, I made sure it was pointing to the same directory where the model and the texture is. So it seems the model is uploading fine, and the server is looking for the right texture in the right place, but the texture doesn’t seem to make it through in the upload.

Looking at the log file now I just noticed that it’s saying “checking uploaded model” twice, one would think it would be saying “checking uploaded model” then “checking uploaded texture”… that could be where the issue is.

@Sapphire saw the post earlier and I gave her the item location too.


#4

The problem was the FBX exporter “embedding” the external textures in the FBX file as empty blobs. These empty textures are ignored so that the actual textures are uploaded, in build 1000.

The multiple “checking uploaded model” messages are expected: it’s just the uploader checking to see whether the model is available on the server yet, and if not then checking again until it is.


#5

Thanks @ctrlaltdavid, tested, working like a charm again…