Nvidia card resets


#1

hi, just to let you know on my Alienware Laptop with Invidia video card, the video card suddenly resets its driver while in Hifi. It does not cause a crash and things go back to normal afterwards, but it does this all the time.


#2

What specific graphics card is this on?

Have you tried with the latest drivers?


#3

Hi, here are the computer’s specs:

6th Generation Intel® Core™ i7 processor
Windows 10 Home
8GB RAM Memory
NVIDIA® GeForce® GTX 960M with 4GB GDDR5

Actually Hifi runs really poorly on this machine, even thou the PC is quite powerful…

thanks


#4

8 gigs is not a lot of memory, especially with Windoze. That might be why that machine is running HiFi poorly.


#5

8GB is plenty for Win10. I don’t think that’s the issue. The weak points are usually the HD, and the number of PCI lanes in the mother board. Note it is a 960M (mobile) so this is a laptop. @Templar, which laptop is this? And, the hard drive, is it s 7200RPM drive, or a hybrid or SSD?


#6

Make sure Hifi is running on the Nvidia card and not on the integrated graphics.

My Alienware laptop is a few years old, with a gtx780m card and runs Hifi just fine.


#7

Interface doesn’t run on the integrated HD4xxx or HD5xxx graphics card (assuming this is what the laptop has in it for low power graphics).


#8

Sounds definitely like the Nvidia Optimus is kicking in and rendering using the i7 integrated instead of the Graphics card.
Not sure if this was tested properly during Alpha since many have just been using dedicated desktops, but it would be good for the developers to note:

Try the following instead.

  1. Make sure your laptop is connected to power
  2. Check your Power Settings and make sure when connected to power, you have everything on High Performance
  3. Open Nvidia Control Panel.
  4. Press Desktop drop down: Select Add Run with graphics processor to Context Menu
  5. Right click the Interface icon, and select Run With graphics, and Nvidia High Performance

Hopefully that helps with the low performance.

However not sure with the Crashing of the drivers. Did you try updating them as well?


#9

There was at least one alpha with a laptop, me :slight_smile:
And I did have to manually select the Nvidia card to run Hifi on. Out of the box Hifi runs on the integrated graphics.


#10

thank you for your replies, here are the machine’s specs…


#11

I am forcing Hifi to run on the nvidia card, so this should not be the issue, moreover it’s the nvidia driver crashing


#12

Hi, I had already the settings like this and performance is still poor. thank you.


#13

Alright, then lets flag some devs.

@Caitlyn there seems to be an issue here, could you check with the rendering guys?


#14

I agree, something is wrong.
BTW, this is exactly the kind of good testing needed to discover the problem points.


#15

Dang, that nVidia Optimus tech is like a toothache! I had the same problems with my new Dell laptop with a 960M, which I ultimately had to return because Optimus simply wouldn’t stay shut off. I’d disable it, then it’d kick back in. Our devs looked into it but couldn’t find a workaround, and nvidia’s tools for disabling Optimus wouldn’t stick. The only solution I could find for folks stuck with Optimus in this case was to go into the system bios at startup and disable it there. Alas, the Dell bios didn’t have an option to disable it.

I wound up going from a rather sleek and attractive Dell to a cumbersome but quite beefy Asus ROG with 980m. Not a satisfying solution. Similarly, “Your machine doesn’t meet the minimum specifications” is an unsatisfying solution! Especially for a newer gaming laptop like this.

Can you give a little more info about the poor performance?


#16

Hi Thank you for the reply. today there was actually a driver update from nvidia, which I off course installed right away. It seems to be a little better now, but I have not had time to test intensively…
Generally speaking the performance on desktop systems with similar configurations is much better.
Let alone that the Oculus never really worked on this machine either, it only works with the test scene…