Particles: Import: polarFinish - Fail to import


#1

If you try to import a particule to a new Particle entity…
pasting this:
{“isEmitting”:true,“lifespan”:“1.2799999713897705”,“maxParticles”:“604”,“textures”:"???URL VALUE ???",“emitRate”:“70”,“emitSpeed”:“0.8299999833106995”,“emitDimensions”:{“x”:“2”,“y”:“2”,“z”:“2”},“emitOrientation”:{“x”:“90”,“y”:“0”,“z”:“0”},“emitShouldTrail”:false,“particleRadius”:“1.8200000524520874”,“radiusSpread”:“0.20999999344348907”,“radiusStart”:“0”,“radiusFinish”:“0”,“color”:{“red”:“255”,“blue”:“18”,“green”:“113”},“colorSpread”:{“red”:“255”,“blue”:“0”,“green”:“221”},“colorStart”:{“red”:“255”,“blue”:“38”,“green”:“208”},“colorFinish”:{“red”:“255”,“blue”:“0”,“green”:“0”},“emitAcceleration”:{“x”:“0”,“y”:“9”,“z”:“0”},“accelerationSpread”:{“x”:“0”,“y”:“0”,“z”:“0”},“alpha”:“0.20000000298023224”,“alphaSpread”:“0.5”,“alphaStart”:“0.5”,“alphaFinish”:“0”,“polarStart”:“0”,“polarFinish”:“85.99999783970858”,“azimuthStart”:"-180.00000500895632",“azimuthFinish”:“180.00000500895632”}

when you click “import”, something get wrong with the “polarFinish” value
Instead to get “85.99999783970858”, I get “4927.436914349499”

The same bug affect also the field:
azimuthStart and azimuthFinish
where I get 10313.240599346875 instead of 180.00000500895632

And I’m quite sure it would affect also polarStart if the value wasn’t 0.


#2

The texture URL would be needed as a means of displaying anything. Try to use the default smoke image and let us know how and if it works. Thanks.


#3

The texture url was only a place holder string in what i pasted here. (Put the one you want to reproduce it)
For the angle, there is a conversion bug. the input be should in degree for the import. (but it behave as if it was in radiant and convert it in degree)
It should be in degree because it’s what the export use. ( and the UI by the way)

the test is simple.

  • Create a particle using angles.
  • Copy the particles data (Export)
  • Create a 2nd particle entity, replace the particle data by the one you just copied before.
  • Press the Import button.

The angle are wrongly imported, because a conversion Rad to Deg is applied.

(A bug tracker would be a good thing to have instead of a forum.)


#4

I misunderstood your request. Valid.

This is one reason (among a few) why I have my own export >> import script. :wink:


#5

It’s not a very sever bug.
I think we will all survive. :wink:


#6

Ah, nice catch, will have that conversion thing fixed (as I made the UI changes to the particle editor), azimuth and polar values should always be radian when exported (because these values should then be usable in scripts) , I guess here the conversion go added even though it shouldn’t have. Degree format is just for UI.

For now, use the Native built in Export rather than the UI one.

Fogbugs usually is where the bugs are posted at, which unfortunately isnt open for all, so submit instead to github issues.


#7

Got it. Next time I will log my bug there.

Euh… Can you explain to my french brain what the “Spread” concept means/does?
I haven’t seen any effects by setting this.


#8

AFAIK spread should add variance of set to the specific effect.

Forexample instead of linear alpha 0.0-1.0, with a spread of 0.25 the particle have a start of 0.0 - 0.25 to 0.75 - 1.0. etc. Best seen with acceleration.