Pause: When did this become a thing?


#1

Did I miss something? While not an under-the-hood girl, I don’t remember hearing about this:

Hoping this can be explained. Thanks.


#2

Its the HMD feature, when you alt tab or go out of the window, the avatar kneels down and then stops updating info for it. activated by pressing a button on the keyboard (for me, the one above alt)


#3

#4

That kneeling is going to look silly in dance place when everybody tabs out to do something else. Or jump into some chat program.


#5

I was suggesting it bein G just he avatar looking blankly into the sky.


#6

When I originally suggested a pause script, I wanted it to have the incoming transmission from the great giant head pose like in 3rd rock from the sun.

course they passed on my idea and now we have this one grins


#7

It is part of a script called away.js . It is mainly for HMD users as your body can do weird things when taking off a headset and hand controllers. This should not show in desktop mode, we will fix this.


#8

@DrFran , is this coming up when you’re in desktop mode?


#9

Yes. I updated, and there it was. I was on the MacBook Pro. Haven’t tried it on the PC.


#10

has anyone on a PC seen this happening?


#11

Just a cultural FYI that when an avatar kneels in front of another, it is an ask for oral cybersex. I’d recommend just leaving the avatar standing, maybe playing a gentle stand animation.


#12

@Chris I saw Pause appearing a lot yesterday on my Windows PC, no Oculus Rift in use or even attached. But I haven’t been able to reproduce today (have tried builds 4252 and 4255).


#13

You can toggle the pause with Ctrl+greater-than-sign Ctrl + > Like @ctrlaltdavid Yesterday I noticed it in a build, and couldn’t get it to go away.


#14

I suggest it hold out a fancy little box containing a diamond ring. :grin:


#15

If this were fully fleshed out, there should be an interface setting in which you get to choose the ‘away’ animation. Lacking one or if the soeified animation cannot be loaded, interface should default to standing (please, not the SL slumped over anim).


#16

Under animation-overrider.json it is defined under roles: awayIntro, away and awayOutro.

This means scripts can also override these roles, so depending on the environment, you can have different animations for being afk.


#17

I see no settings like that for interface. Where again should I look?


#18

Updated on the MBP, and it’s fine now. Thanks.


#19

animation overrider .json is defined either via
Accessing Setting> Avatar > Avatar Tuning > Avatar Animation JSON.
The default animation-override.json is at

High Fidelity Install Directory/resources/mesh/defaultAvatar_full/avatar-animation.json

You can also use scripts to override entire graphs, or even specific roles, such as:

MyAvatar.setAnimGraphUrl(jsonURL)
or

MyAvatar.getAnimationRoles() : Returns a list of roles
MyAvatar.overrideRoleAnimation(String role, String url, int fps, bool loop, float firstFrame, float lastFrame)
MyAvatar.clearRoleAnimation(String role): to reset.

Forexample,

MyAvatar.overrideRoleAnimation("away", "http://www.norteclabs.com/HF/animations/silly_dancing.fbx", 30, true, 0, 100)

will set your away animation to the dance animation. use MyAvatar.clearRoleAnimation(“away”) to remove


#20

Thanks for that detailed information. I would never have found it there since it is a violation of standards to let an application dynamically alter the program install files. It means whenever interface is updated, those ‘settings’ would get overridden. Glad to see there is the facility for animation roles, but yikes, it needs to be moved to AppData settings on Windows or in the app data fork of the application package on OS X.

Maybe what happens is if I call those methods and change the defaults that the change gets reflected into interface.ini. Will try that.