PBR reflection problem


#1

PBR is a monster.
I have problem, some object started to reflecht the sky.
I tried to change all setting in specular in different combinations,
it does not disappear.

@menthal, what am doing wrong.
i have specular.roughness at -1 in blender (tried 1.0 to)
i tried with different combinations whith intensity and color with no luck.
specular in materials section is set to black and intensity to 0.0

I used a other object i made to modify that to get the new one.
But all old materials are deleted after making the UV-map.
so the glass must be gone etc.

rougness check with debugtool is showing light grey.
It just looks like some settings are ignored.
A problem i hit more with some things.
I would call it hidden material properties.

ADD: ok it need to be white roughness . but blender is doing something weird.
I now have a white roughness and still shiny.


#2

Other strange problem to with light. the top is more white.
Edge split did not work, if not where applied.

It’s one of the weird days that it’s going complete wonky with hifi and some object.


#3

You mispelled my name so could have missed the thread, there is the autofill to help you to avoid that :slight_smile:

Anyway, you only have to set Specular hardness to set the roughness. There is no ‘roughness’ value in blender, unless you go to and use cycles, which you are not supposed to do as FBX does not support PBR. Just review the video I did on PBR, of which still applies to date

In Blender, if the specular hardness is 0, this means the roughness is 1.
This means there the surface scatters the light, making it matte. Setting this value to negative will not invert it, instead it will just set it to 0.

If the specular hardness is 511 (max value), the roughness is 0.
This makes the surface glossy.

To reflect the skybox, the skybox must be of a certain intensity. Otherwise the material must be metallic

Above is with an environment that has an intensity of 1.5.

Same applies to Textures you do from (only in) Blender, where white = rough, black = glossy. The inverse if doing it in any other program.

Specular Color can only be either 0 or 1, this defined if the material is non-metallic or metallic : there is absolutely no inbetween.

Do note that in the current 6008 there are reflection issues which @sam is working on that are fixed in the next versions (reflected map is odd when roughness is near to 0)


#4

@Menithal I normally use autofill.

Ok, i tried it again, i know it’s specular.hardness. WHat i do not know is why that settings is not doing anything ! High fidelity just ignore in cases the settings. i have the same problem with blednshape tree i tried. i can change settings but it does not apply everywhere.

I just changed hardness, like i always do.
Made a new fbx, with a new name to be sure
that the stupid cache does not bite me again.

No… luck.

Send you a link to the file, because am curious what you think.
If i do not find the solution.


#5

Got the file, used the FBX:

Any color information you feed into the texture -> converted to grey scale. So if you apply just
"Color" maps as the textures you will not get the result you want but they also arent converted like greyscales from blender that are inversed when placed into the model, ask sam bout that one.

This is what it looks like when the color is just slapped in and converted for High Fidelity.

In blender you were using the color map for -all the channels- and this will not always end up with the best results. As we see here, the door is -very, very, reflective-.

Remember this?

Specifically, the Top is Roughness how High fidelity interprets it. White = Matte, Black = Shiny. Thus the colors are absolutely inversed for the roughness of the door.

So If we want to make it look correct, then>

We have to remember, with this in mind When Roughness is in High Fidelity, and the model comes out of blender, the values are inverted because blender exports Glossiness! So, if we want to create some

Thus in both cases, the fbx defaults to just using the Specular values from the Material view (not texture view)

What I noticed though is issues with Embedded textures, especially when the textures are png with alpha, try jpg instead or just keep it separate.


#6

Going to check, High Fidelity drives me nuts
Some people from the high fidelity tream asked me to use png instead of jpg because that worked better or something like that. And now you say the opposite.

The material stuff in high fidelity is one of the confusing parts.
Going to check and see if i get it right. Still need to understand what you did.

It’s anyway still strange that the object changed
with modify from not reflective to reflective.

Anyway, how do you got that reflective view in blender ?
I do not see that. Or hard to spot.

Thanks for the check @Menithal


#7

PNG only if you are planning to try to keep transparency or want to have generally good quality texture,
but if not you better make sure you are not using alphas in the textures, there is a lot more to remember to check with those. plus due to filtering and the texture compression, everything is compressed anyway, so there is not that much loss for jpgs, unless you are doing skyboxes, where they look horribad.

Otherwise, most texturing issues arise from embedding the textures to the model, as they usually get switched around among other things due to some odd bugs that i also encountered while doing fixes to your model.
So my suggestion is compartemization: so instead, when developing a model, make sure to work with a non-embedded version first, finalize it, then after that battle with the embedding.


#8

I always need to embed it in the FBX in test state. if everything is right i go worry about seperate it to normal textures in directory i hope i can use then in high fidelity.

Not sure wich embedding you mean. i just select the tgexture i need in the blend file from the same directory where the blend file is. So the are as far i know not embed


#9

As in Embedding the textures into the FBX files. that tends to cause issues that I havent gotten around to checking cause of.


#10

Hmm, i never have problems with embedding textures in the FBX. and really is the only way to go right now in high fidelity. ATP is to bad to support seperate textures. Also never tried that.

Ok. after a pile of (#%#@%) :grinning: and looking at your video i finaly found the hardness in blender. :flushed: All the time i where changing wrong specular in the texture settings.

Alpha textures and embedded are no problem. It where just the specular.hardness. This specular !

Thanks @menithal !
Now i need to document that on my own docs.

After edge split it looks perfect. Normal maps etc. i add someday. not see it as required right now. Now i need to change the other objects to the right settings and i can try the tree again.


ADD: Oh, noo. it’s still there. now i look at the inside. :frowning:
High Fidelity roughness tells me, it must be ok.

But i still have some reflection.

Can edge split on baked UV-map create this ? One way to figure out. test it.
Ok, that make no difference. It’s better, but reflection is not complete gone. After a relog it seems complete back.

AHA ! @menithal , your right. that alpha is the problem.
Except i keep the small reflection still on the door like the above pictures show.

@menithal, i see that you did add more materials i try to avoid for now.
I want just only diffuse. i go check your example. and if needed i need to adapt. It still does not explain why this door got wonky and other things work fine.

ADD: Lot’s of above is still biting me.
I now have add a grey texture to hardness and intensity, that would be roughness and metal. that lower the reflection. but there’s still shine. a complete black texture seems not to work.

Still prefer to not need to use it at all. Better stop for today.
It’s ossibl;e quick , faster and safer to make the object from sratch. then i do not have this spontanic problem with materials menithal can fix and i still do something wrong. :open_mouth:


#11

This is what you have to wrap you head around, because its quite specific to High Fidelity due to the stupid inversion thing

Specular Hardness 0-511 = That is specifically controls and maps as it to High Fidelity, Black = matte, White = glossy

In High Fidelity there after it will look correct, Where in High Fidelity it is Black = glossy, White = matte.

Until you replace the texture with the texture swap method, which is when it will be as it is as a texture.

Use the debug deffered Lighting to make it easier to check on the, the images are hard to tell because of the darkness.

You can also always simply load the model directly from the file system without uploading it to any ftp or atp, until you are ready to show it and distribute it to everyone else. Forexample.

Then to talk about the door, the thing is that the example I provided was on purpose slightly reflective but not by much, because all surfaces always reflect light, with bump mapping it would look quite good, but since it is a flat surface it looks like it just reflects the other end slightly.

If you want it completely matte, simply replace the roughness with the metal texture and that it, it will then simply distribute all the light across the surface isntead of reflecting it back.

Just note that Even if at 0, the surfaces will always reflect a version of the skybox, but it should be more subtle, see my sphere example above. Current version has a skybox bug though, so you may see corners of the skybox from some angles. its fixed in next stable release.

Also note, do not use the same file texture, even if embedded between metallic and roughness, otherwise that will give you headache as well because both will get inverted.


#12

lolcats @ money XD…


#13

Hmm, money. @Menithal is the rich person in High Fidelity. :grinning:

Anyway, still trying to get it right. someway it’s right. Someway it’s still wrong.
I do not want to add extra useless textures i do not use at this point. I got menithal’s door pretty right. hardness = 1.

The real problem stated after i baked the textures to UV map.

  • The left door is the one before it where baked to UV map. looks perfect no difficult disasters with settings. like it always worked.
  • The center one is menithal door. seems ok.
  • The left one is my latest try.

The p[roblem is that in the right door. My latest try with this settings.

I keep seeing the skyBOX as reflection in the door. So annoying, because it looks fine at first impression. The door seems not matt enough, and i do not get it matt enough. Only using the default texture.

So i do not get the latest reflectioin gone. I do not want to use extra textures.
And i still not understand why everything got spontanic shiny after baking the UVtexture.

This going to take years to unerstand, for now it’s faster to remake the door again or from scratch. With all the messing around somethings on the door broken.


#14

You don’t need to tick the specular intensity channel if you’re not using a metallic texture. You also would not want to set it to -1, the value should always be one so you can control the level using the texture.
Untick the Specular channel on the texture, then on the material set the specular intensity value under the black color to 1, I don’t think it needs to be 0, it uses the colors black or white.


#15

Tried that before. but when i set that it looks better.
Intensity did make it worse when i did set it to 1.0. I can retest it.
Note that there are no other textures then the color one in my last test.

But righgt now i make the door from scratch and fix a few small alignment problems i found. See if i bump in the same reflection problem.

I made lot’s of things without problem, and then the reflection and metal sneak in. without any reason. That’s the real weird problem

Normal, and just did the test again. is this enough to work with it.
more settings are not needed. But bledner did something weird with baking it to UV map. Hope it works this time.


#16

@Triplelexx is correct

Additionally, as I mentioned, if you are going to embed textures into the model, or fbx you must make sure to have separate channels for the model because the fbx will lose the information of which texture belongs where.

What texture are you baking into it, how are you baking it, and why are you baking it.
if it is just binding the projected textures then it shouldnt effect anything else but the active texture.

If you want just the color and “nothing extra”

  • Set Diffuse Color Texture: Make sure not to use alpha on the texture channel.
  • Specular Color black
  • Specular Hardness to 1
  • Make sure to have a good skybox map and lighting
  • Do not bind any texture to any specular channels.

Any textures you apply to the model, will override any settings you have in the material.

Anything else I will type in here will just be circularly repeating my self over and over again.


#17

Do you mean different materials ? otherwise i do not understand what you mean. I always use different materials for different textures.

In this case the orginal that looks perfect in high fidelity have 3 materials. That i bake into one material. it worked manye times before fine with other things. Then i generate a new UV texture. That texture i assign to a new material that have the whole object assigned to it. Then i delete the old materials.

Diffuse color texture without alpha or with alpha makes no difference at all. I now saved the UV map as jpeg from inside blender. It keeps glossy.

Deleting the Thick Clouds Skybox Zone make no differen without it i still see a glossy look.

Set Diffuse Color Texture: Make sure not to use alpha on the texture channel.
Specular Color black
Specular Hardness to 1
Make sure to have a good skybox map and lighting
Do not bind any texture to any specular channels.

As far i see i have not set more then that. there’s only one material active and one texture (the UV baked one)

Again the problem start when i bake more materials into a new texture and assign that to a new material and set everything right. i hve done this many times before without any problem.

Now i replaced the skybox for one that’s i would say not so good. Ocean Skybox and then i do not see the strange glossy look anymore. WIth this skybox things seems fine. Tried it on simsquare with other skybox. problem is back

This with the oceanic skybox. the only one that seems not to have reflection.
Reflection only appears when i baked different materials into one new texture.

This on simsquare domain.

this are the settings on the door.

Am stuck. until i find a good manual or figure out what the real problem is. Tempted to blame high fidelity. FBX review is showing things like i see it in blender. where all running in rounds.

Having now skybox problems on my localhost. something with height incorrect. Is there something that works in high fidelity without any problem ?


#18

Oceanic Skybox does not have any environmental mapping because it is a shader skybox. Thus there is no shine, but everything will look dull and dark.

You have to apply an ambient skybox url texture to the ambient light for you to have any effect.

Any lighting in the shader skybox zone will be wonky without the ambient url being set. Best always to apply an ambient url if using one of the shader skyboxes. It is not correct because it will then look incorrect to you in other domains.

Without a zone it will look incorrect. Please refer to using debugDefferedLighting to checkout any issues with the model, and specifically refer to roughness and metallicness. Because the two go almost hand in hand

Make sure after baking that there is no use of alpha. in the final texture, this can cause issues.


Again the problem start when i bake more materials into a new texture and assign that to a new material and set everything right. i hve done this many times before without any problem.

Please make a video of this process so I can understand exactly what you are doing and comment on what you may be doing that can cause issues. Especially the material part

this are the settings on the door.

This doesnt tell me much, it only shows settings for a single texture. Send me the blend file again.

To make sure we are speaking the -same language here- here is a reference


#19

The wiki not telling anything about ambient url.
So only some god knows what you need to use as ambient url.

Here’s my reference i used on the last door. Ill send the blend and UV texture


#20

Its a thing they need to make more clear for the users.

If you use a user create shader skybox it has to have an equalevant ambient url, because there is no texture to reflect off the surfaces.
Re: @AlphaVersionD, it needs something default honestly as it gives the wrong impression of lighting since its fantastic skybox.

You could, forexample
copy the texture url use in the Thick Cloud Skybox Zone, and apply it to the Ambient URL of the Ocean Skybox

like so: