Place names and Bookmarks update!


#1

Hi All,

Exciting couple of updates:

  • Connecting up your place names
  • Moving over your locations to bookmarks

Connecting up your place names

You can now connect up your place name in 4 ways.

  1. A place name to a domain
  2. A place name to a path, within a domain
  3. A place name to another place name
  4. A place name to a path, in another place name

Moving over your locations to bookmarks

“My Locations” is being replaced with Bookmarks. A Bookmark is stored locally on your machine and is created through the menu within Interface:

If you have been using “My Locations” as a bookmarking system, now is the time to migrate over. We are going to leave “My Locations” up in a read-only state, to help people migrate.

Let me know if you have any questions?

Chris


#2

Thank you so much for this and I think this is really taking HighFidelity in a great direction and can’t wait to see how it grows moving forward!


#3

Going to test and move stuff tomorrow.


#4

Thanks @chris for writing this up. As before, your places won’t show up in our directory/lobby without an image. If you are mapping over a location that had an image, you should be able to click on the link in the ‘My Locations’ table so that you can get the image and upload it for your new Place.


#5

What sort of delay can we expect before seeing place names linked to domains showing up in the directory? My place names for hifi://Openvue and hifi://OpenVCE are not showing up after I set them up an hour or so ago… and I have checked I have an image attached to the place names, and a valid security token and the stack manager for both domains are operating.

Also, I see that if I set a default arrival location (as I thought of it) of say /10,0,0/0,0,0,0 for a domain place name then whenever I use a specific address such as hifi://Openvue/50,0,50 that I still arrive at the /10,0,0 and with the orientation I set in the default place. I expected the specified location and orientation to override. Is this just a temporary glitch that will be fixed? Its not the expected behaviour I think.


#6

Yuck… the bookmarks are local to one instance of the Interface and not carried over when you log on via another computer. Isn’t it time we associated some elements with a log in name rather than an instance of the Interface? Things like

a) avatar model
b) bookmarks
c) last location


#7

Where is 'My Locations" its removed from the menu, now i cannot access it inworld. Need todo it the difficult way from the webpage. So, not readonly @chris its just removed. Lost of openinging new windows, copy url , paste url. because the path from webbrowser to viewer is still noty fixt when installing interfece.exe its still pointing to the c: drive. Warned about this many times and months ago to fix that asap. and now its creating more and more problems.

I see a problem in the bookmarks to. You cannot make subfolders. so if the list is getting to long i dont know what happens. this problem will be hit faster on small screen then desktop.

Cannot finish conversion from my locations to bookmarks because this problem.
https://alphas.highfidelity.io/t/server-changes-stop-you-getting-in-your-domain-16-01/1277/2


#8

My place names were set to point to my domains with the correct DomainID, and an image, and the stack manager (updated to win 52) is running for each domain, and the security id is in place for each. But after 4 hours the place names do not appear in https://data.highfidelity.io/directory

What sort of delay between setup of a place name and its details to appearing in the directory do you expect @Chris ?


#9

@Ai_Austin it should be immediate. When you go into your placename does it look like this (note the Points to is an id)


#10

@Ai_Austin syncing for those things and more is definitely an important feature we want to add. Syncing is easy to get wrong so we haven’t thrown it in the client just yet.

Note that the bookmarks are stored in a separate JSON file. It is conceivably possible to sync that file via dropbox (or some other similar solution) between machines but that is not something we have tested.


#11

The second thing you mention in this post is definitely bug that I will fix. Thank you!

I believe the reason that your places are not showing up in the directory is that you do not have an access token set in your domain-server. Without it the domain-server can’t heartbeat back to us so we do not have a way to tell if it is online.


#12

Yes @Chris it looks like that but is still not showing for places Openvue and OpenVCE places and domains owned by @Ai_Austin

I see @b note and will check that now.


#13

@Ai_Austin also do you have a Access token on those stack manager?


#14

Yes, I did that this morning, and just checked they are in place and not missing any characters. As belts and braces, I already generated a new access token earlier today rather than reusing ones I had before to be sure. Both domains have the correct access token I generated on the My Security page.

Sending you the screen shots by e-mail @Chris as I assume the security IDs and domain Id association so on should be kept secure.


#15

@Ai_Austin, can you send me your Domains Server log.


#16

Sent by e-mail @Chris

Note that the domain name does show in the stack manager on start up after briefly showing hifi://localhost and I do seem to be able to get to the location using the Interface with address hifi://Openvue

But I do see errors in the stack manager logs… on QSslSocket: in batches of 5… I assume that’s the issue?

WARNING] [01/16 19:09:02] QSslSocket: cannot call unresolved function SSLv23_client_method
[WARNING] [01/16 19:09:02] QSslSocket: cannot call unresolved function SSL_CTX_new
[WARNING] [01/16 19:09:02] QSslSocket: cannot call unresolved function SSL_library_init
[WARNING] [01/16 19:09:02] QSslSocket: cannot call unresolved function ERR_get_error
[WARNING] [01/16 19:09:02] QSslSocket: cannot call unresolved function ERR_get_error

I tried a clean reboot of the server, and also tried both none (as it was originally) and fully automatic networking. No difference.c


#18

I also have an issue with image not showing on directory, I believe I have it all set correctly, token, ID, path, image


#19

Has the port range changed that a hifi domain needs… or maybe there are new requirenents for SSL? Currently the instruction is…

Port range that must be open (or properly forwarded if behind NAT) is 40100-40105 (both TCP and UDP).


#20

@Ai_Austin can you quit stack manager and restart to get the latest update.


#21

The latest is stackmanager-win-52.exe @Chris. I updated to that before I started this morning… so its already the latest that was in use throughout my attempts to get it going. And I have rebooted the server several times during the testing too, so no old versions kicking around.