Protocol unknown


#1

Can anybody tell me what “protocol Unknown” means please?

Every other fbx object I try to upload gives this warning and no model appears inworld.

I have tried to change everything to figure out what this cryptic and unspecific message means but I cannot isolate it.

Anybody?


#2

Which host site are you using for your uploads and what kind of mesh are you trying to upload?


#3

Im using a regular webserver, and its a building from a 3d model download site.


#4

You want to open the model in 3d software and see if it is all mesh and that the mesh has a texture.
Some free 3d mesh look ok in the software they were made in, But the exporting might have had errors, the mesh very high in poly count or the file size of range for Hifi.


#5

I appreciate that you’re just trying to help so thanks for your input.
I have done extensive modifications to this model in blender, it has many textures and many materials, some textures are alpha some are not, the textures are all available in folder and are of optimum size and packed. Some materials have no texture but all mesh has material. (you dont need texture but must have material)

The materials are of various shadings including Blinn and Cook Torrance, and some semi trans. I think I heard of an issue with Phong which is why I mention this.
Some surfaces are smooth some are flat.

The mesh is quite high poly count and the file size is big, BUT this model has been imported successfully before so size is not an issue, there must have been something I introduced in the last 5 mods that has caused this issue.

I am familiar with missing texture errors, tga errors, server errors, missing file errors, texture too big errors, inverted normals errors, non-manifold errors, and a host of others.
I have been importing models into hifi for over a year and every now and then I get this error, so once more from the top.

Do you know specifically what “Protocol Unknown” means please?


#6

Unfortunately I have no idea where the protocol unknown error comes from in the first place. Doesn’t seem to be anywhere in the HiFi source code too.

It can’t also be about the materials as those bugs appear… Differently, as you may know. Blenders phong also currently works fine, and is the only material which appears for now.

It sounds like its talking about the url protocol definition, but do you have any further logs on it? Also have you looked into the server logs when rezing? Does the green box atleast appear? Have you tried just uploading a box model to your host?


#7

My guess would be an https:// access was made and the SSL protocol was not acceptable to the server. Good servers no longer allow weak or compromised secure protocols.