Re Meet Up @Chris - my Domain Entities Lost on Log Out


#1

Two issues
problems with Stack Manager
ONE. Intermitent window message - on attempt to Edit my domain “You do not have the necessary permissions to edit on this domain” - sooo sometinmes i can Edit and sometimes I am denied (seems 2me that mostly i am denied)
Check => Remove my username ‘Allowed users’ & uncheck box ‘Allowed Editors’ - Result no change

TWO.All Entities lost on Log Out from my Domain - 3 Entity sources tried : a rezzed cube, palm tree from market place, an entity rezzed from from script using 'entity_floor.js’
Check => Edit/Entity List & Refresh - "No entities found…"
All these entities do persist when i rez them in Sandbox but lost from my Domain.

Accessible at hifi://arklo
Today 10:20 11/04/2015 Header reads @arklo (not connected) (build 2275)
Chris suggested Check => SM/Settings/Nodes and check Entity Server is running
Result = audio, avatar , entity servers all show Uptime

then View Logs
DS Log
[DEBUG] [04/11 08:56:10] No match for assignment deployed with “7f041e37-4d6e-499c-a8ca-db672ed2a602”
[DEBUG] [04/11 08:56:11] No match for assignment deployed with “7f041e37-4d6e-499c-a8ca-db672ed2a602”
[DEBUG] [04/11 08:56:12] Received a request for assignment type 7 from 127.0.0.1:59332
[DEBUG] [04/11 08:56:12] Unable to fulfill assignment request of type 7 from 127.0.0.1:59332
[DEBUG] [04/11 08:56:12] No match for assignment deployed with “7f041e37-4d6e-499c-a8ca-db672ed2a602”
[DEBUG] [04/11 08:56:14] Unable to fulfill assignment request of type 7 from 127.0.0.1:60115

Assignment Client Log
[DEBUG] [04/11 08:56:12] [avatar-mixer] Local domain-server port read from shared memory (or default) is 40102
[DEBUG] [04/11 08:56:13] [assignment-client] Assignment finished or never started - waiting for new assignment.
[DEBUG] [04/11 08:56:13] [assignment-client] Clearing the NodeList. Deleting all nodes in list.
[DEBUG] [04/11 08:56:13] [assignment-client] NodeList UUID changed from “da3fc2cf-6caf-4634-adfe-a0383733edc3” to "00000000-0000-0000-0000-

000000000000"
[DEBUG] [04/11 08:56:13] [assignment-client] Resetting current domain connection information.
[DEBUG] [04/11 08:56:14] [assignment-client] Network told me to exit.
[DEBUG] [04/11 08:56:14] [assignment-client] Exiting.
[DEBUG] [04/11 08:56:14] [assignment-client] Cannot create address path without a getter for position. Call AddressManager::setPositionGetter to pass a function that will return a const glm::vec3&


#2

I’m having that exact problem, I cant edit right now anything…


#3

@ritzo @polygonmonster when you go to allowed editors, does it look like:

http://localhost:40100/settings/#security

Also, when you go to http://localhost:40100/ can you see and entity server running?


#4

No Editors are declared - left blank
’Only editors can create…’ - is unchecked

audio/avatar/entity/agent all show up time

tried Stack Manager update - no change


#5

@ritzo can I go to the domain and try it?


#6

thanks - ok i will leave it running until 1700 hrs PST


#7

Can you also add ‘chris’ as an editor?


#8

chris added
and no other editors


#9

one thing i just noticed-
if Stack Manager ISNT running and i re- launch Interface while i am in Sandbox and then go to myDomain arklo - then i DO have Edit permissions
Well at least i can upload from a URL, but thereafter have no ability ( clicking on it has no effect) to edit the entity i just uploaded. There is also  No Edit possibilities when clicking entity in Tools where it seems to highlight one of the ;domain ‘anchors’ (ie. where the RBG lines have their  origin)
After closing interface (No SM running)
Relaunch interface with avatar @ arklo
Again i have no edit perms on myDomain


#10

@ chris the problem of entities being lost on log out is now resolved, entiities i create on my domain using scripts now persist.
However i can still not create nor edit using the basic ‘Edit power button’. Others have suggested reinstalling everything but i note the recommendation not to update the stack manager until further notice. Suggestions? or Wait ?


#11

Removed Stack Manager, new install 70.
No change … "You do not have edit perms on this domain"
Nor can i download eg.
Striking Red Door…Created by highfidelity


#12

Resolved
C:\Users\xxxxx\AppData\Local\High Fidelity\domain-server\High Fidelity\domain-server

“security”: {

“allowed_editors”: [
 
               “”
        
    ],
        
    “editors_are_rezzers”: false,
        
    “maximum_user_capacity”: “5”
    }

Remove all from betwen {}
to read
"security": {
        
    }
Reinstall

*shouldn’t L11
"editors_are_rezzers": false,
 
 read :true ?


#13

@ritzo I would recommend editing your security from the security tab. http://localhost:40100/settings/#security . Also, can you email me your edited file?