"Refusing connection from node at 127.0.0.1:42373" ... What is this?


#1

I found this in my domain server log at startup. What is this?

[DEBUG] [09/19 11:54:58] Refusing connection from node at 127.0.0.1:42373
[DEBUG] [09/19 11:54:59] No match for assignment deployed with “0c8ca831-b89c-4cff-925d-e16760321138”
[DEBUG] [09/19 11:54:59] Refusing connection from node at 127.0.0.1:42373
[DEBUG] [09/19 11:55:00] No match for assignment deployed with “0c8ca831-b89c-4cff-925d-e16760321138”
[DEBUG] [09/19 11:55:00] Refusing connection from node at 127.0.0.1:42373
[DEBUG] [09/19 11:55:01] No match for assignment deployed with “0c8ca831-b89c-4cff-925d-e16760321138”
[DEBUG] [09/19 11:55:01] Refusing connection from node at 127.0.0.1:42373
[DEBUG] [09/19 11:55:02] No match for assignment deployed with “0c8ca831-b89c-4cff-925d-e16760321138”
[DEBUG] [09/19 11:55:02] Refusing connection from node at 127.0.0.1:42373
[DEBUG] [09/19 11:55:03] Unable to fulfill assignment request of type 7 from 127.0.0.1:42373


#2

https://www.google.com/search?redir_esc=&client=tablet-android-samsung&hl=en-US&oe=utf-8&safe=images&q=ip+local+loopback&source=android-browser-type&qsubts=1442679029870

Forgive me if you are already fluent with ip configs, etc. Outside of debugging, this is what I came up with.


#3

Lol, I know what localhost is. I just want to know why my domain server is trying to connect with itself on port 42373. This is running on a remote ubuntu VPS. Is this a problem or business as usual?


#4

Judging by the complexity of some of your posts; I kinda figured you did. :smile: anyway, good luck with that.


#5

That usually indicates you have an excess of ACs running for DS’s need. Since it’s on localhost it’s, obviously, originating on your droplet.


#6

Ahh that makes sense. Maybe one didn’t die when I killed the process last. Thanks OH.


#7

Hrmm well when I run AC it executes 5 copies of it. It looks like all 5 are refused. Is it important they be allowed to connect?


#8

Well, the key is to look at your web based DS controller whatever_ip:40100 and see if you have 3 (or maybe 4 if using ATP) processes showing as being served. I’m not sure how you’re starting ACs - I don’t use the spool up X ACs with Y spares command line option, instead, I spool up what I need with types set as in assignment-client -t 0 (audio) -t 1 (avatar mixer) -t 3 (ATP) -t 6 entity – there’s nothing better about that way - it’s just my old habits. If I ran any entity scripts needing server side I’d add a few spare script executors. Maybe that’ll help some in sorting out why you have some excess.


#9

I just start up AC with no command line arguments. DS shows audio, entity and avatar nodes active, nothing else. I am not serving any DS scripts (yet). Well I guess I will figure it out eventually if I find something not working correctly.