Release 5407 - No sound at all?


#1

As of updating yesterday I see to have lost audio in the interface. Regardless of what input or output I select, the log keeps barfing out “Unable to set up audio input because of a problem with input format”.

At first I thought maybe it had something to with this weird monaural headset that I use, but even after switching over to just my computer’s built in audio it still gives the same thing.

Is this maybe just a thing with my hardware setup or … Help?

[10/01 15:05:28] [DEBUG] [VERSION] Build sequence: 5407
[10/01 15:05:28] [DEBUG] [VERSION] MODIFIED_ORGANIZATION: “High Fidelity”
[10/01 15:05:28] [DEBUG] [VERSION] VERSION: “5407”
[10/01 15:05:28] [DEBUG] [VERSION] BUILD_BRANCH: “stable”
[10/01 15:05:28] [DEBUG] [VERSION] BUILD_GLOBAL_SERVICES: “STABLE”
[10/01 15:05:28] [DEBUG] [VERSION] We will use STABLE global services.
[10/01 15:05:28] [DEBUG] Registering a packet listener for packet list type 62 (AssetMappingOperationReply)
[10/01 15:05:28] [DEBUG] Registering a packet listener for packet list type 54 (AssetGetInfoReply)
[10/01 15:05:28] [DEBUG] Registering a packet listener for packet list type 50 (AssetGetReply)
[10/01 15:05:28] [DEBUG] Registering a packet listener for packet list type 52 (AssetUploadReply)
[10/01 15:05:28] [DEBUG] DEBUG [ “Headset Microphone (2- Plantronics C610-M)” ] [ “Headset Microphone (2- Plantronics C610-M)” ]
[10/01 15:05:28] [DEBUG] The default audio input device is “Headset Microphone (2- Plantronics C610-M)”
[10/01 15:05:28] [DEBUG] The audio input device “Headset Microphone (2- Plantronics C610-M)” is available.
[10/01 15:05:28] [DEBUG] The desired format for audio I/O is QAudioFormat(24000Hz, 16bit, channelCount=1, sampleType=SignedInt, byteOrder=LittleEndian, codec=“audio/pcm”)
[10/01 15:05:28] [INFO] Loading runtime plugins from “C:/Program Files/High Fidelity/plugins/”
[10/01 15:05:28] [DEBUG] Attempting plugin hifiCodec.dll
[10/01 15:05:28] [INFO] ResourceManager disk cache setup at “C:/Users/orion/AppData/Local/High Fidelity/Interface” (size: 10 GB)
[10/01 15:05:28] [DEBUG] Plugin hifiCodec.dll loaded successfully
[10/01 15:05:28] [DEBUG] Attempting plugin hifiNeuron.dll
[10/01 15:05:28] [DEBUG] Plugin hifiNeuron.dll loaded successfully
[10/01 15:05:28] [DEBUG] Attempting plugin hifiSdl2.dll
[10/01 15:05:28] [DEBUG] DEBUG [ “VX2370 SERIES-4 (NVIDIA High Definition Audio)” ] [ “VX2370 SERIES-4 (NVIDIA High Definition Audio)” ]
[10/01 15:05:28] [DEBUG] Plugin hifiSdl2.dll loaded successfully
[10/01 15:05:28] [DEBUG] Attempting plugin hifiSixense.dll
[10/01 15:05:28] [DEBUG] The default audio output device is “VX2370 SERIES-4 (NVIDIA High Definition Audio)”
[10/01 15:05:28] [DEBUG] The audio output device “VX2370 SERIES-4 (NVIDIA High Definition Audio)” is available.
[10/01 15:05:28] [DEBUG] The desired format for audio I/O is QAudioFormat(24000Hz, 16bit, channelCount=2, sampleType=SignedInt, byteOrder=LittleEndian, codec=“audio/pcm”)
[10/01 15:05:28] [DEBUG] The format to be used for audio output is QAudioFormat(48000Hz, 16bit, channelCount=2, sampleType=SignedInt, byteOrder=LittleEndian, codec=“audio/pcm”)
[10/01 15:05:28] [DEBUG] Attemping to create a resampler for network format to output format.
[10/01 15:05:28] [DEBUG] Plugin hifiSixense.dll loaded successfully
[10/01 15:05:28] [DEBUG] Attempting plugin oculus.dll
[10/01 15:05:28] [DEBUG] Output Buffer capacity in frames: 2.2 requested bytes: 1920 actual bytes: 4224 os default: 4096 period size: 1920
[10/01 15:05:28] [DEBUG] Unable to set up audio input because of a problem with input format.
[10/01 15:05:28] [DEBUG] The closest format available is QAudioFormat(16000Hz, 32bit, channelCount=1, sampleType=SignedInt, byteOrder=LittleEndian, codec=“audio/pcm”)


#2

What version of windows are you running?


#3

@ZappoMan - I’m in Windows 10:

[10/03 20:03:41] [DEBUG] Build Information
[10/03 20:03:41] [DEBUG] Build ABI: x86_64-little_endian-llp64
[10/03 20:03:41] [DEBUG] Build CPU Architecture: x86_64
[10/03 20:03:41] [DEBUG] System Information
[10/03 20:03:41] [DEBUG] Product Name: Windows 10
[10/03 20:03:41] [DEBUG] CPU Architecture: x86_64
[10/03 20:03:41] [DEBUG] Kernel Type: winnt
[10/03 20:03:41] [DEBUG] Kernel Version: 10.0.14393
[10/03 20:03:41] [DEBUG] Windows Version: 192
[10/03 20:03:41] [DEBUG] SYSTEM_INFO
[10/03 20:03:41] [DEBUG] OEM ID: 9
[10/03 20:03:41] [DEBUG] Processor Architecture: 9
[10/03 20:03:41] [DEBUG] Processor Type: 8664
[10/03 20:03:41] [DEBUG] Processor Level: 6
[10/03 20:03:41] [DEBUG] Processor Revision: 0x3c03
[10/03 20:03:41] [DEBUG] Number of Processors: 8
[10/03 20:03:41] [DEBUG] Page size: 4096 Bytes
[10/03 20:03:41] [DEBUG] Min Application Address: 0x0000000000010000
[10/03 20:03:41] [DEBUG] Max Application Address: 0x00007ffffffeffff
[10/03 20:03:41] [DEBUG] MEMORYSTATUSEX
[10/03 20:03:41] [DEBUG] Current System Memory Usage: 16%
[10/03 20:03:41] [DEBUG] Avail Physical Memory: 20550.40 MB
[10/03 20:03:41] [DEBUG] Total Physical Memory: 24521.94 MB
[10/03 20:03:41] [DEBUG] Avail in Page File: 23531.98 MB
[10/03 20:03:41] [DEBUG] Total in Page File: 28105.94 MB
[10/03 20:03:41] [DEBUG] Avail Virtual Memory: 134216964.27 MB
[10/03 20:03:41] [DEBUG] Total Virtual Memory: 134217727.88 MB
[10/03 20:03:41] [DEBUG] CPUID
[10/03 20:03:41] [DEBUG] CPU Vendor: GenuineIntel
[10/03 20:03:41] [DEBUG] CPU Brand: Intel® Core™ i7-4790K CPU @ 4.00GHz


#4

Hi @Orion.Pseudo can you try this build http://cachefly.highfidelity.com/HighFidelity-Beta-PR8706-9590d2e.exe and let us know if you get audio?


#5

@chris - No luck I’m afraid on that build either. I’ve tried both using my headset (a single speaker usb Plantronics monaural with mic) as the input /output and also switching things around to use the headset mic as the input with the computer’s soundcard for the output but I’m getting the same results either way.

Below are the full logs for both attempts if they can hopefully be of any help?

Plantronics as input + output: http://pastebin.com/S4nnJyGU
Plantronics as input + nvidia as output: http://pastebin.com/bRDXMHH4


#6

The most I can guess is that maybe this weird old headset of mine is throwing a wrench into the works. I’ve tried just unplugging it and running with just the output set to the speakers but still no luck (even on http://cachefly.highfidelity.com/HighFidelity-Beta-PR8721-6838dc0.exe).

I’ve gone ahead and ordered a new headset that plugs right into the audio card (http://www.newegg.com/Product/Product.aspx?Item=N82E16826193025) so in a couple of days maybe I’ll have better news! :blush:

Curious question - is it required to have both an active input and output in order for sounds to play through the interface or should it just work without a microphone?


#7

It should just work without a microphone (although I think old builds did not do that).


#8

Is it possible for you to pipe stereo audio into your monaural headset? Are you on a Windows machine, and can you change your audio settings to stereo?


#9

@zzmp - Interesting… Then in theory I should at least be able to hear things with the interface pointed at my speakers (either via the nvidia adapter or the realtek on the motherboard). Its strange as the only error that seems to show up in the log is that the input has a problem, nothing regarding the output.

As for my trusty old Plantronics, I’m afraid it doesn’t seem to have that option. I’ll do some more poking around to see if the manufacturer has any sort of software for it though. Either way, it served me well over the years through many Skype and SL voice chats, but it is getting kind of long in the tooth. In the mean time, the new headset should be on the way - provided hurricane Matthew doesn’t blow both the delivery and myself off into oblivion within these coming days. So, fingers crossed! :slight_smile:


#10

Make sure in windows the default device is set correct.
Also check if in high fidelity the correct device is selected.
If you run steamVR carefull, that can screw and change default devices to.


#11

@Richardus.Raymaker - Check on all three. I’m running things in keyboard / mouse mode (no vr for me yet), so steam isn’t an option. I downloaded / installed the plantronics software for my headset, but other then a quick firmware update that seems to have cleared up a few glitches with the headset itself there was no change.

I’m just gonna have to wait until the new headset comes in (probably late next week at this rate since the hurricane is likely to delay shipments to my area) to see if that helps at all. :smile:


#12

Hi @Orion.Pseudo I found and fixed a bug related to 16KHz input devices. I think it might address your problem. Can you try this build? http://cachefly.highfidelity.com/HighFidelity-Beta-PR8739-d6aa74c.exe


#13

@kencooke - BINGO! That fixed it! Well, mostly… I have sound again with this release, and I think the microphone on my Plantronics works! The meter is showing input and echoing back the server audio sounds pretty good. However the audio output on the headset comes through garbled - almost like a record being played at a slow speed. Switching the output over to my speakers seems to clear that up though, so it may be a matter of a little tweaking on my end. :smiley:


#14

@kencooke - After running into some folks over at Welcome I can confirm that the mic does indeed work. Although even after tweaking the format settings output through my headset speaker still causes everything to come out slow and distorted (like a combination of a Darth Vader voice morph and a record playing at too slow a speed). Either way, its usable now with the audio piped through my speakers and once the new headset comes in all should be well.

Thanks everyone for all of your help! :smiley: Just to forewarn, chances are that tomorrow sometime I’ll be knocked offline for a few days depending on what happens with the storm. My apologies in advance if I’m slow to answer, but rest assured I’ll get back just as soon as the power and internet are restored! :sunny:


#15

Thanks for testing @Orion.Pseudo. Is your headset speaker only a single (mono) output? The artifact you describe sounds like stereo being played back through a mono device, which would cause a slowdown / pitchshift effect. We only support stereo output devices in this release.


#16

@kencooke - Its a single speaker, yes ( http://www.plantronics.com/us/product/blackwire-600?skuId=sku5480022 ). Up until now I’ve only ever used a headset for Skype and SL voice so I always stuck to a single ear telephone style. Good thing I ordered a new one! :slight_smile: