Resolved: Crashing with Oculus


#1

Crash Log:

I just got my Oculus DK2 (yay) and finally decided to give Hifi a try with it. Upon logging in, I ran into a few problems, which was related to the 64bit client for Windows (was still running 32bit, was running 32bit but version references were from the newer 64bit; solution: uninstall everything and try again). After that, I got access to my Sixense controllers again (Razer Hydra), and I could select the Oculus again. Huzzah!

The problem comes WHEN selecting Oculus from Display. The moment I do, it crashes immediately. I’ve already flushed my cache completely, along with all settings.Upon reading the first crash log, I decided to try setting all display settings to default: Unlimited with V-Sync Off. After reading the users.js file in regards to the weird ‘isOptionChecked’ thing, I also enabled fullscreen. Oculus Mode and… crashed once more (second log).

Okay, so I decided to try hmdDefaults.js this time. Tried once more and… well, you get the picture. So, at this point, I can’t nail down where the crash is truly coming from. I will admit HiFi has been a struggle due to my slow internet (5D/0.5U), but normally I can determine where the problem is from the logs. I am running multiple monitors and I hope this isn’t causing the issue because having to unplug my monitors just for Hifi would drive me up the wall in less than 5 seconds.

Is there something I should look into regarding this? I am very excited to finally get the most of this VR experience and am really trying to find out what is preventing it from happening.


#2

Hi @FlameSoulis few think to make sure.

Ensure that you are using the Oculus 0.8 runtime and that your graphics are up to date.

Chris


#3

@chris Yeah, when I first had to set up the Oculus, it blared at me in regards to the drivers. I find the Direct2Oculus thing rather interesting.

Anyhow, I should have mentioned my specs: (slightly out of date, but the hardware is the same, nevertheless) http://valid.canardpc.com/ceh3ip

My nVidia Driver is currently 359.06 (latest as of this post) and I am running Oculus 0.8 runtime.


#4


#5

@FlameSoulis have you tried it with other demos?


#6

Yes, and all work very well. Before I started getting a very unusual bug from SteamVR, I was giving The Talos Principle a try in VR mode (with amazing results, by the way), as well as other Oculus Rift demos (Windlands, Technolust, the built in desk demo, as well as AutoPlayVR (a media player for VR)), so I am aware the Rift is set up properly and does function in the VR demos as expected.

In fact, testing out the devices on my system was how I was able to find out about the 64-bit version of High Fidelity, since my Razer Hydra was not showing up under devices. After getting that set up and confirming the Hydra was working (Surgeon Simulator and the default 3D tester in the configuration UI) in HiFi, that’s when I knew I could start testing the Oculus. In fact, the initial version I downloaded was the very build that included the 0.8 SDK (3725 I think it was). The last I have tested so far is 3786.


#7

Just an update, I have it working. 3850 seemed to fix whatever was previously ailing me.