Resource to describe optimal flow from makehuman to highfidelity?


#1

Hello,

I’m trying to figure out how to get my avatars out of makehuman and into high fidelity. I have the MXH2 plugin installed in both locations and working fine, and I have @Menithal 's blender plugin installed but can’t figure out quite the right flow. I’ve also followed the flow on this page without success (none of the bones are mapped when I try to import the FBX into high fidelity package). Creating and rigging an avatar with Blendshapes in Makehuman

If I press the ‘make human’ button in the blender plugin I get an error "Attribute Error ‘nonetype’ object has no attribute ‘head’ which calls in the ‘correct_bone_positions’ function.

I note that the avatar doesn’t come into blender in T-pose so there maybe something wrong with my makehuman export or the way I’ve rigged the avatar in makehuman.

Is there a canonical description of how to do this somewhere?

Thanks,
Antony


#2

Did you follow the steps detailed here? HiFi MakeHuman instructions


#3

I had not, but I was able to get things working by following those instructions. I did have a minor issue which might be worth adding to the documentation, which was that after importing (via the blender addon) my hands were giant and I couldn’t move. I was able to fix this by editing the fst file to set scale = 0.01. It might be because I selected decimeters rather than centimeters during the export from makehuman, or it might be something else.

Before figuring out the fixscale adjustment I also shrunk all the texture files as I thought it might be that first. That might have been required to fix, I’ll test in a future update.

One issue remains which is that the mouth doesn’t seem to be responding when I talk, but I’m going to look into that now.

thanks for your help!


#4

Thats great that you got it working. MakeHuman is pretty cool. I guess you could customize the mesh in zbrush easily and still get it to work?

Eager to see if you get the mouth to Lipsync properly, I hope so! Good Luck!


#5

The first thing to check is that the blendshapes were added to the fst file correctly. Add the ones listed at the bottom of the instructions I posted.

If those are there in the fst file, then the next thing to check is whether “Face Shapes” was checked during the import of the mhx2 file into blender.


#6

Thank you, it’s working now. I’d missed the ‘faceshapes’ checkbox!