Rough terrain shadows


#1

Although it looks different in the blender and the FBX viewer, terrain shadows are displayed very roughly in hifi. In blender and the FBX viewer the transitions are softer.

I tried it with following settings in blender, but it does not change.
material->shading->cubic interpolation
textures->blend: from Mix to Multiply

Can you improve the appearance somehow? Or can the Hifi render not better that at the moment?


#2

@JuelsDrekiI am unable to see my SkyBox at the moment did the code change?


#3

https://alphas.highfidelity.io/t/skybox-dissapeared-after-updating-stack-and-interface-3830/9959


#4

@KevinMThomas
Richardus was faster. :wink:
Yes I know. My skybox shader is not to see too.


#5

any luck yet with it back?


#6

One word suggestion to shader developers in HF: sigmoids.


#7

The Link to your shader works, and the source code has not changed. My skybox shader works again. So this should be no different with your.


#8

Do you thinking at a contrast setting with a sigmoid function? Like here:

https://www.shadertoy.com/view/MtX3z2


#9

Hi @JuelsDreki it still does not work. This is what i have currently am i missing something? Perhaps I am missing something?

{
"ProceduralEntity":{
    "version":2,
    "shaderUrl":"http://metaversecafes.com/HighFidelity/QueenCity/shaders/night_wave_ocean_v7.fs"
    }

} 

#10

Will look at that when I’m home from holiday in a week and not on $10/GB hotspot.


#11

The calls for my shaders are:
{
“ProceduralEntity”: {
“shaderUrl”:“http://juelscrafthut.eu/assets/shader/nightsky_hifi.fs
}
}

or (not the night version):
{
    “ProceduralEntity”:  {
        “shaderUrl”:“http://juelscrafthut.eu/assets/shader/seascape_clouds.fs
    }
}

But you use a shader from Alpha​VersionD. He can tell you certainly, why his shader is not working. :wink:

look here: https://alphas.highfidelity.io/t/adapted-cloud-shaders/9806


#12

All right, I’ll wait. Have a great holiday yet. :slight_smile:


#13

I just tried:

{
"ProceduralEntity": {
"shaderUrl":"http://juelscrafthut.eu/assets/shader/nightsky_hifi.fs"
}
}

in my user data of my zone and it is not working? I selected skybox as well.


#14

It could be a bug. My skybox shader works only, if a skybox texture is specified too in the field “Skybox URL” (red mark).

Here my skybox settings:

The skybox texture:
http://juelscrafthut.eu/assets/skyboxes/BlueSkyOcean.jpg


#15

Yes, that’s an old bug. You must have a sky texture, but then it can be something as simple as a white texture. Then, the shaders can be adjusted…


#16

what about the day one with the ocean?


#18

ahh! oh ok I see now. I had a missing ; working now thanks!