Running an Assignment Client


#1

We have just released an installer for the MAC Assignment Client (AC). Linux and PC to follow.

Getting Started

  1. Download the AC from here: http://public.highfidelity.io/assignment-manager/assignment-manager.zip
  2. Extract and run. This will then put a nice HiFi icon on the task bar.
  3. When you first load it will download the software needed, it will also update itself when we update.
  4. Get your wallet id by visiting http://data.highfidelity.io
  5. Go to the ‘Setting’ and copy your Wallet id to the field provded

  1. From there you can stop and start the AC. Make sure you Start the AC.
  2. When you login to Interface you will see your balance slowly going up.

What does it do

  1. If you want to see the AC running in on your system you can open a Terminal and type
    "ps aux | grep assignment" . It should show both an assignment-manager and an assignment-client line. If it does, it’s working.
  2. This version of the AC connects up to alpha.fidelity.io and makes itself available.
  3. If the Alpha domain server needs an AC it will then grab an available one

The Bigger Picture

When you run the AC, we will credit you with currency when we use it.

It is all very exciting.


#2

YAY it works! This is great!


#3

Is there a way to get the linux command line version of the assignment client to connect to the alpha grid? Is there a way to change resource allocation with the client to use 100% of the resources of a machine? I have a couple Ubuntu servers I’d like to try this on.


#4

think i have it running. This is a whole different style of party.


#5

anybody who installed, please make sure you hit “Start” for the assignment-client to actually await for an assignment. Show log should show you a line saying:

[assignment-client] Waiting for assignment - UUID: {00000000-0000-0000-0000-000000000000}, Type: 2


#6

Could you comment on firewall requirements? Open ports? There was also another thread where we were discussing routers that didn’t have IP loopback support, so maybe a comment about general requirements for first-class participation in the HF cloud would be useful.


#7

I really just cannot wait for the Linux “packaged” version, but I can see some great potential in how this is going so far. I did install and run it on my Mac already.


#8

Step 1 is a bit tricky.

Qt5.3 installed to my home dir with the qt installer, but the client expects qt to be at /usr/local/opt/qt5
I had to make that dir and copy the files from /Users/Marcel/Qt/5.3/clang_64 to it to get the assignment client running.


#9

The assignment-client seems to have installed correctly and it says that it is running but when I open the “Show Log”, it is just a blank log. Does this mean it is running or not?


#10

No an empty log means it is not running


#11

Hi all, I’ll have an updated version of the assignment-manager that will not require Qt to be downloaded/installed manually and that will allow you to set wallet, pool and domain on runtime, stay tuned :wink:


#12

That is awesome because I had to do the Qt5.3 link just like @MarcelEdward did to get mine to function. I am glad to see it coming along so well!


#13

Hi all. @leo has updated the assignment client to auto install QT and allows you to put in your Wallet id. I have updated the instructions above. Have fun.


#14

Got a little bug report on mine. I ran the new one, it says it downloaded as you described but now in the “standard error” I get this:

dyld: Library not loaded: /usr/local/Cellar/qt5/5.2.0/lib/QtCore.framework/Versions/5/QtCore
  Referenced from: /Users/computer/Library/Application Support/High Fidelity/assignment-manager/QtNetwork.framework/Versions/5/QtNetwork
  Reason: image not found

I do not use brew and its referencing a brew location I notice by “Cellar.”


#15

The current brew qt5 is 5.2.1 - I was able to make it work with (assuming you already have brew installed):

brew install qt5
ln -s /usr/local/Cellar/qt5/5.2.1 /usr/local/Cellar/qt5/5.2.0

Oh, and for some reason, the usual paste keystroke didn’t work in the settings type-in box, but right-click paste did. Weird.


#16

guys, I missed some dynamic library path-changing in the Qt frameworks, I’ve just uploaded the fixed Qt. Please do the following:

  1. Quit the assignment-manager if you have it running
  2. From a terminal, run the following command (it will ask for your password, please enter it): sudo rm -rf ~/Library/Application\ Support/High\ Fidelity/assignment-manager
  3. Run assignment-manager again

If you installed Qt5 with brew, you can uninstall now if you feel like it :wink: Thanks!


#17

All seems to be working well now! I took the parameters passed from this AC via the settings and am using it on other ACs to test and am watching my “credits” build up quite well which is fun it it self.


#18

Is accruing credits the test that it is actually participating in the grid? I see a continuous stream of adding-activating-killed services when I run from my office machine. I see at the beginning of the dialog that it is using STUN to try punching through NAT, but the work net is… atypical. I am getting some credits, so perhaps I’m just overly suspicious?


#19

@mthome currently, all ACs that are joining the credits pool are being served the same script (a game of life script that plays in the edge of the world and it’s difficult for you to find your instance of the script) - we started in this way just to test things worked - that will change soon however and you will get more specific tasks and be able to more easily identify what it is that your assignment client is doing in world.

I think your adding/activating/killing loop may be caused due to the nature of the script, saturating your outbound pipe with more packets than it can handle. Thanks for the report and I’ll let you all know when your clients will be getting more specific and visible tasks.


#20

I had the AC up and running and everything seemed to be working. At least my little bit of “income” was increasing and I had a constant stream of stuff on my log screen. Now the little H icon has disappeared. I tried to reload the AC but that didn’t work. Any suggestions for a total newbie when it comes to this stuff?