Sandbox and Interface issues on Windows but not Mac


#1

Hi,
I am a new user to High Fidelity, and have a 2012 Mac and a new Windows 10 machine that is used to run my HMD (HTC Vive) and has an NVIDIA 1080 graphics card. I have no problem with running Sandbox and Interactive on my old Mac. I can go into my Home and move around in there, etc. My friend has no problem entering my Home (using temporary address) with his remote Mac (with my Mac acting as server). However, I can not enter my Home (again with my Mac acting as server) using my Windows machine. Further, I can’t launch Sandbox and Interactive on my Windows machine, so when I launch Sandbox on my Windows machine, I can not “Go Home”.
Ideas as to what is going wrong?
Blue_Canary


#2

Hi!

Welcome!

Not sure if I’ll be able to be much help. But if you can provide a little more info we may be able to.

Are you able to launch interface in Windows at all? If not what happens when you try?


#3

Please also describe the process you use to complete that. Are you entering the temporary name into the address bar? Instead, try localhost; if that fails try local loop back.

I run Sandbox and Interface in-house but upon different machines and have had occasional odd networking problems.

Also, @hevyw8 was at our meeting yesterday and we noticed @humbletim was having issues due to a (without getting too invasive) complex network setup using multiple Routers/Firewalls. As Heavyw8 has kindly requested; help us help you with maybe a few more details.

thanks!


#5

Thanks for the responses @hevyw8 and @AkphaVersionD

I can launch Interface in Windows and go to Playa and walk around with my Vive no problem.
I can also enter go to my friend’s Home running from his Mac on his wifi in his home, and again no problem.

The problem is super specific to when I try to launch Sandbox on my Windows and try to enter the Home via Interface with “Go Home”. Interface just sort of ‘wigs’ out is how I would describe it. I get either jumping in and out, a partial rendering, or just a sky screen in my Vive. In the 2D display, I just get sky screen.

I then tried to launch Sandbox on my Mac computer which shares the same network as my Windows computer that runs my Vive. On my mac, I could enter into the Home via Interface no problem. My friend could enter my Home running on my Mac via Interface no problem. but when I tried to enter the Home via my Windows, again, problem. I put in the temporary name, and it goes nowhere but sky screen.

We played around with Firewalls, and settings, and to no avail…

I will try localhost and local loop back later tonight which may fix the trying to enter the Home running on my Mac, but does not explain the inability to run Sandbox and Interactive simultaneously on my Windows machine and being able to Go Home from the tab there. My Windows machine has got much better specs than my Mac and I was hoping to run a server on it.

Partly I was wondering if it was not an issue with the drivers for my graphics card. I have an NVIDIA 1080, and the drivers have been constantly updated by NVIDIA due to this problem and that problem. At one point I got an error message that implicated my graphics card drivers. Anyone else running Sandbox and Interactive with the latest 10-series graphics cards?


#6

I’m running a 1060 but I think I’m one version behind on drivers. I haven’t seen anything like this.

I’m not terribly well suited to help troubleshoot, I’m afraid. But the very least I would recommend trying is a uninstall and reinstall. But I imagine you’ve already tried that.

Sorry I couldn’t be of more help! Hopefully someone else will have some good next steps.


#7

Lets clear a few things up, I have seen similar issues because I have tried all kinds of setups with various computers on the same network.

First double check the setup.
You set up sandbox on the Mac for example, and you need to forward the ports on the mac and point your external IP to the mac, so the router knows which comp to forward the incoming interface connections to.

You then change and try the same thing on the windows box, you need to change the forwarding to point incoming connections to the windows machine now, or it tries to connect to the existing mac forwarding
I am going to assume that you have correctly forwarded the ports from the specific computer on your router. For each test.


Make sure that the Mac sandbox is not running at the same time as the windows sandbox.
If it is then the Mac has control of the metaverse settings and wont let Windows play.

If you have used the same temporary name and settings for both then you will encounter conflicts as the system cant decide which of the 2 domains running the one domain ID to send you to.

Always completely quit out of the Mac sandbox, when running Windows sandbox and vice-versa.

I suggest you grab a second temporary domain name and set both computers up as completely different domains, then it wont matter if they are both running.


#8

Not saying anything applies to your situation but just to say what my experience here has been.

My first domain here was the Avalon/Capitola domain/placename. I set this up probably two years ago with manual settings. Default settings with fixed ports, router loop back and firewall rules, etc. At the time it was the only way to do it.

Later I added the “content” domain/placename which I set to Auto networking.

It worked (works) well as long as things are done in correct order.

I must start the manual domain first. And then start up the auto networked one. If I do it in this order, they both work. If the manual setup one crashes and then I happen to restart the Auto networked one, I have problems because the auto networked one responds now to the IP of the domain that was supposed to be for the manually setup one.

For me the solution might be to set the manually setup one to be some random port, or to just not use manually setup network and set them all to auto. I’ve yet to try this because it is small problem here.

Another thing I will be testing more soon maybe is running 3 or more from same IP.

This may not be of any help to you but I am just saying what worked/didn’t work for me.


#9

Agreed; but, what if this person is using the same temporary placename on different machines I personally made two different ‘sandbox’ machines, and when they generate their domain id hash they were different (which makes sense logically) so for full automatic networking to config for two different physical machines sharing the same temporary placename… i’m lingering around this as the persons root cause.

That’s my take.

@Menithal any issues with running Stack Manager? see 1080 comment.


#10

Nope, I havent experienced any issue related to the 1080 and sandbox, and it would be unlikely for that to effect the running of the sandbox (stack manager).

My second machine that behaves as a dedicated server doesnt have any graphics card too, and it works fine.

@Blue_Canary, is there any reaction when you start either the sandbox or the Interface client? Have you tried reinstalling them?


#11

@hevyw8: thanks for the info! My friend just got a Windows computer with a 1070 and it works just fine for Sandbox and Interface, so it’s something particular to my machine… I’ll figure it out and report here :slight_smile:


#12

@AlphaVersionD and @Menithal and @Adrian and @TwaHinkle: I’m going to run through all of your suggestions today and will report back. I’m starting to suspect it’s something particular to my machine as my friend has it working fine on his, which is similar to mine except I built mine and his is prebuilt and a 1080 vs 1070. So I’m going to check if its my machine, my settings, and report back here… thanks so much for the help!!!


#13

I updated my drivers for my graphics card (Founders Edition 1080) and now Sandbox and Interactive works on my Windows. Not sure why this is so but it worked :stuck_out_tongue: