Server changes stop you getting in your domain 16/01


#1

@Adrian talked me through it

in settings check you still have access and domain id codes in
go to https://data.highfidelity.io/directory
then my locations
copy the path you want
then go to my place names
click edit and paste that in the path box
go to your domain server(the settings button on ur stack manager)
copy the domain id
go back to place names
paste it into to points to


#2

i can indeed not go to your domain to create a new bookmark. useing this adres :

hifi://robotdolly/8017.98,195.069,8058.46/-0.0003174,-0.993243,-6.17273e-05,0.116051

Same problem for my own domain,

hifi://SimSquare/128.985,336.182,140.841/7.69232e-05,0.69759,-7.9008e-05,0.716497

Well, done for now. This way i cannot convert my locations to bookmarks


#3

if u made the changes and its not showing in the into the lobby then u need to add in a photo in the my place names(only shows the image upload when u press edit)


#4

The dont need to show right now in the lobby. i first need to create the bookmakrs :open_mouth: And like @judas told, thats not working. Teleport failing with message. Some links you dont want in the lobby anyway, just a bookmark for own use.


#5

@Richardus , if robotdolly is not a registered place name and is not pointing to a domain. It will not work. @judas does that make sense?


#6

nothing makes sence to me lol i got it working again later via adrian


#7

Ok - this will likely sound crazy, but, follow along.

IF you’re using the option in your domain server of Full automatic networking (which is in most cases the best/proper option) then you must must must, can I stress this more? MUST. Go to data.highfidelity.io then My Domains tab and make absolutely certain that the field Network Address is blank. Otherwise it does not properly map back via the ICE calls that all this full auto stuff uses to make it easy mode.

Perhaps that’s something our coders needs to look at :wink: All this stuff about opening ports and forwarding and so on is usually not necessary (firewall rules are an entirely different matter). If you setup your domain server with full automatic networking, blank that field and apply it, restart stack. 99.9% Chance you’ll be up, running and done.

@b Could you look at this. It’s likely going to lead to a lot of support issues if it remains as is since it, effectively, breaks the magic of Full auto networking with port/ip.


#8

@judas and @richardus .

@richardus , is trying to get to a location:

hifi://robotdolly/8017.98,195.069,8058.46/-0.0003174,-0.993243,-6.17273e-05,0.116051
AND
hifi://SimSquare/128.985,336.182,140.841/7.69232e-05,0.69759,-7.9008e-05,0.716497

robotdolly: is not a registered place name. Therefore will not go anywhere.
Simsquare: is a registered place name, yet is not pointing to a domain. Therefore will not go anywhere.

Does that make sense?


#9

SimSquare i try to point, wanted to make a picture. but cannot get to my domain. so cannot make a picture and finish things.

Maby judas have changed names, and i where not at bright time of the day.
Going to look into it now.


#10

Hmm - it should be preferring the fact that auto networking is on, no matter what you have in the network address field. I will double check that.

What is really key is that you have an access token in your domain server so that we know that you have automatic networking turned on. This is also how we have your domain heartbeat to us so that we can tell if it is online or not.


#11

just created the access token, that where not in the file or got lost.
I think things work now here, replaced old judas for a new judas… :slight_smile: (shop)
I hope the following screen dissapears soon to, because High Fidelity is not installed on the C: drive.


#12

Yes, I actually posted this amidst something unrelated and apologize for that, but, with an access key present, full automatic networking on - if an ip is in place you find that things like clicking names in chat to transport to don’t work, and various other routing issues appear. It seems something is getting confused somewhere by IP field being in place. Many have suggested you need to open ports on router then map to the internal IP to fix this issue when, with automatic on, blanking that field makes it all work.

My ultimate torture test for routing is this setup.

Cable modem -> wired/wifi router 1 -> wired connection to 2nd wired/wifi router -> wifi connection to 2nd router -> vmware vm 1 acting as a NAT router to network 3 -> vmware vm 2 running stack on network 3. With no other configuration other than full auto networking on - clients from internet can get to stack traversing 3 NAT points. But - it all breaks if you have an ip address in that field (as it should) unless full auto is on - so something somewhere is getting confused as I’ve helped myself and several others solve routing issues where that was the fix.


#13

@leo can we figure out how to handle case where interface is not on a C drive?


#14

yeah I’ll make the install path user definable (and use that path wherever we must define it) @b

L


#15

Okay - so I tested this just now - with a domain that has a network address, if I turn on full automatic networking the API returns that I should talk to the ice-server.

However I did notice something weird that I will look into which is that a DS token I’m pretty sure I generated yesterday didn’t work this morning. I generated a new one and gave that to my domain-server and then it was fine


#16

Also try giving it an incorrect ip address. Then confirm you can have someone teleport to you via clicking name in chat while logged in. It’s subtle where this is (seeming to) fail.


#17

@b - No idea if you or someone else made a change somewhere, but, suddenly I now have to place my IP into domain config or I’m unreachable via placename even with domain-server running full auto ip/port.


#18

I ended up deleting my old domain attached to the legacy domain name Heron, generated a new one and it’s all working smoothly again with IP field left blank and domain-server running with full automatic networking. My attached placenames had disappeared from directory and this fixed that as well - though they were previously visible (and visible after the new system rollout). Easy, painless fix. Highly suggest it to anyone having trouble getting shown in directory or having any other strange problems with domain routing. You lose nothing deleting a domain instance and the time to set domain-server to new UUID and placename to match is minimal.