Significant Voxel Issue


#1

I found that when I began removing voxels on my plot that after an undetermined amount of voxels were placed and then removed and then attempted to be re-created that a significant limit bug issue evolves.

I originally thought that because I was using over 3 million voxels on my 200x200 meter area it was an issue with too many voxels for the server to handle however I am building a tutorial set for constructing houses in another area @genesis on the main grid and I am finding the same issue however only a few thousand voxels are created.

There is some back-end bug where after a certain amount of voxels are placed and then removed and placed again, the effected area will only create back a few at a time.


#2

I seemed to have tried a number of different things and I think I have found a solution to this issue:
1)If you have any loaded scripts that are on your harddrive, physically create a new folder on your desktop called NEW1 and place them there.
2)Once moved, reload your script from the NEW1 folder and see if your voxel set will load.

What seems to be happening is the build currently has a bug in it where it saves all of the locations of every script you load locally and sometimes calls them back into focus without the input of the user.

This can cause an issue, for example, if I had loaded an eraseBuilding.js script I crash and when I relog it is not there however when I run a new makeBuilding.js, it creates a portion and then starts to erase a portion.

I wanted to be clear as well, this post is different from my other voxel post which was related to having a very large amount of voxels in a 200x200 meter area. That is separate from this issue and therefore is a different post.