Smooth/flat shading of entities


#1

Hi there,

something is wrong with flat shaded entites when uploaded to HF. These rocks, made in blender, looks always smooth shaded, even they were exported as flat or smooth from blender. Maybe a bug in HF? Or do I something wrong?


rocks in Blender


rocks in HF


#2

I don’t have it in front of me, but I think in the FBX exporter tab there is a setting to apply smooth shading, do you really want to see every face/edge? this usually isn’t very appealing unless you are building a disco ball.

Are you using modifiers in Blender? make sure to apply in object mode before export.


#3

Hi @whyroc. Thanks for reply. Unfortunately there is no ‘smooth’ fbx export option. And yes, for some stuff I would like it would looks rough :thinking: - at least I would like to have a choice


#4

You should use edge splitter modifier if you are using Blender, I dont think there is distinguishment between flat / smooth, as “all” are smooth or all are “flat” (althought not in high fidelity without the following trick).

This is usually in all engines, even in Unity, unless you specifically set a flat shader to the object.

Easier is just to use edge splitter (Blender) to get around it


#5

#6

I’ve been able to import both smooth and flat faces pretty sure.

Ok the smooth option was in the .obj export UI… The ‘tangent space’ option under the mesh tab of FBX export UI could help


#7

That’s it :grinning: thanks @Menithal, always a great help!