[Solved] Hifi server stack on Ubuntu Server


#1

Hello everyone and Happy 2016!

I know this is an old issue i’ve had in the past andIi put it to bed for a while until I had a moment to poke at it with a stick again, and I wanted to start a new thread to get some fresh perspective and (hopefully) more up to date information.

I’m trying to get HiFi to compile on ubuntu server, as it was suggested a few months back that this is the direction everyone seems to be going now, so i set up a VM with Ubuntu 15.10 server

I did try a few old tricks but as i feared, they resulted in build errors as before, but i want to ask if anyone has any general advise on steps they took to get the HiFi server stack to run properly on their machines…
I’m open to a Linux version change, if 15.10 has known issues and t works better on 14.x etc.

Assuming this is a clean slate and i’ve not done anything yet, a fairly straight forward way of doing this?


#2

Pretty much everything you can get to get you going with this is in;

https://alphas.highfidelity.io/t/howto-setup-digitalocean-ubuntu-15-10-droplet/10094

There’s nothing uber specific to digital ocean droplets in there - it’s same process regardless.


#3

Thanks @OmegaHeron. I really appreciate what you @thoys and @Coal have done to support linux!

@Ronnie as Omega has stated I just tested this as early as this morning. If you follow the link and have any issues send me a message and we will get you some help.


#4

Thanks for the replies and support guys!

I’m having mixed results with this one (always my luck)

While the aforementioned steps ‘appear’ to have worked on the not so clean VM,

I spawned a shiny new one here at home to run the same commands, and alas have some build errors

 [13%] Building CXX object libraries/shared/CMakeFiles/shared.dir/src/LogHandler.cpp.o
In file included from /home/hifi/hifi/libraries/shared/src/LogHandler.cpp:22:0:
/home/hifi/hifi/libraries/shared/src/LogHandler.h:25:15: error: ‘QtInfoMsg’ was not declared in this scope
     LogInfo = QtInfoMsg,
               ^
/home/hifi/hifi/libraries/shared/src/LogHandler.cpp: In function ‘const char* stringForLogType(LogMsgType)’:
/home/hifi/hifi/libraries/shared/src/LogHandler.cpp:47:9: error: duplicate case value
         case LogDebug:
         ^
/home/hifi/hifi/libraries/shared/src/LogHandler.cpp:45:9: error: previously used here
         case LogInfo:
         ^
libraries/shared/CMakeFiles/shared.dir/build.make:882: recipe for target 'libraries/shared/CMakeFiles/shared.dir/src/LogHandler.cpp.o' failed
make[3]: *** [libraries/shared/CMakeFiles/shared.dir/src/LogHandler.cpp.o] Error 1
CMakeFiles/Makefile2:437: recipe for target 'libraries/shared/CMakeFiles/shared.dir/all' failed
make[2]: *** [libraries/shared/CMakeFiles/shared.dir/all] Error 2
CMakeFiles/Makefile2:139: recipe for target 'assignment-client/CMakeFiles/assignment-client.dir/rule' failed
make[1]: *** [assignment-client/CMakeFiles/assignment-client.dir/rule] Error 2
Makefile:170: recipe for target 'assignment-client' failed
make: *** [assignment-client] Error 2
hifi@ubuntu:~/hifi/build$

#5

@Ronnie did you install the PIP package for QT?


#6

https://alphas.highfidelity.io/t/howto-setup-digitalocean-ubuntu-15-10-droplet/10094


#7

I only followed the instructions on the post you linked me (for the new vm), I assumed they would be in the apt-get command you have posted? though looking through I don’t see any pyqt packages in there :S

I got it to compile and run fine on the other VM that i’d already tried some stuff on, maybe on that one some extra packages are installed? im trying to re-produce the desirable results on a clean Ub15 install :smiley:


#8

@ronnie did you create the swap file as well? In the tutorial there is that step as well. I literally just checked it on Ub 15.10 yesterday and it works.


#9

I didn’t think it was needed since my VM already has an Active SWAP space?

ron@ubuntu:~$ free -m
total used free shared buffers cached
Mem: 3934 195 3739 5 8 55
-/+ buffers/cache: 131 3803
Swap: 4093 0 4093


#10

2.Add remote repo for installing QT5.5 and updating Ubuntu for the latest dependencies.
apt-add-repository ppa:canonical-qt5-edgers/backup-qt551
apt-get update


#11

Ahah. Bingo… for some reason apt-add-repository returns command not found… shouldn’t this be a default ubuntu command? or did they roll a dice and decide to remove it in this release… odd

Admittedly i dumped the commands in bash file late at night so i could let it run while i focused on other things… my bad for missing that one!

will run sudo apt-get install software-properties-common
and try again :blush:


#12

and Add remote repo for installing QT5.5
apt-add-repository ppa:canonical-qt5-edgers/backup-qt551


#13

Yep no build errors this time, thanks guys!


#14

Awesome! Can’t wait to check out your new build @ronnie.


#15

Would this work for Debian SID? How would that PPA be entered in sources.list manually? Ric