Stack Manager Issues


#1

I restarted my stack manager on hifi://hifi.aiai.ed.ac.uk this morning and it appears to have updated the usual set of resources successfully, and it indicates its running with the usual "Accessible at hifi://localhost message.

But I was not able to connect with the Interface it reports (NO CONNECTED).

On the Stack Manager GUI I tried the “View Logs” button and all entries are empty, and I tried the “Settings” button and that says “Page Cannot be Displayed”.

Where do I start to work out what is wrong? It was working fine when I last checked about a week ago.


#2

Hey
The last problem i had was the assignment clients of the stack were changed to be 64 bit and i was running it on 32 bit windows, could this be the problem?


#3

Ah that’s it… my system is 32 bit. is there a 32 bit version of the Stack Manager?


#4

Annoyingly it seems not . I would hang on as next week they are combining the interface and stack into the um was it the workbench


#5

I have been seeing if I can shift onto a 64 bit Windows 10 System,… but now I am getting errors that msvcr120.dll and msvcp120.dll are missing. I tried a manual install of the Microsoft Visual Studio redistributable vcredist_x64.exe that others with this issue have suggested but that makes no difference. And on checking the 2 files it reports an issue with, they ARE there in C:\Windows\System32

Oh dear… the Stack Manager Windows 97 version does not mention that it only runs on 64 bit systems and it worked fine until a week or so ago.


#6

Yes, it’s a mess. I think their installer has some dependency bugs, notably with loading this:
https://alphas.highfidelity.io/t/missing-dlls-in-stack-manager/10064


#7

The change only happened mid last week


#8

I tried a range of things, but eventually stumbled on this… Install the Stack Manager.exe with admin level authority when its run and that seems to fix it.

Note I was already an administrator when trying before, but that’s not sufficient it seems.


#9

HI,

There will be an update to controlling your server with a new program called “Console”, it should be released very shortly. In the meantime you can install the 64bit version from here: https://www.microsoft.com/en-eg/download/details.aspx?id=40784

Chris