Stay away too long and it gets difficult


#1

The difficulty is that I can no longer select entity properties. I can rez stuff, I can upload but I seem no longer to be able to edit something that I select. I have no idea why this is so. I am listed in settings as a user who can do these things. Where am I going wrong?


#2

That’s very, very odd. Have you tried resetting and clearing all the cache and reloading all the scripts?


#3

I cleared cache and reloaded scripts without any change in behavior. I bring up Entity List and can click on any entity and it appears that I can edit, but, I can not.

I can not click on Grid tab or Entity Properties. I can add an entity and even rez it and while doing that I am able to manipulate it. Once I am out of Edit I can no longer alter anything.

I have mostly used a mouse and have difficulty using my xbox controller with movement too severe for any fine adjustments. I do not have touch and really don’t have a driving desire to own them as I am not a gamer but AM a VR enthusiast. In any event Editing for me is no longer possible beyond adding an entity,

Another odd behavior is that if I click on Edit then Entity List, nothing happens until I repeat the procedure and then the edit box comes up. HiFi is very frustrating to build with even though I am not an average user being able to build models, rig and animate. I am a Maya user and do not have these problems with other engines.


#4

This is some very odd behavior, because (like everyone) mouse and keyboard is the way to go for building and using the edit scripts (because we yet to have any such fine control in VR or using the gamepad).

Does this only occur on your domain, or have your tried in other domains like the Welcome area?

It sounds like something in your domain is causing the issue of unable to edit the properties more than the edit scripts. Are you sure none of the entities present are being automatically locked (because as soon as they are locked no one can move them)?

There also is the possibility than your login has expired: Have you checked if you have to login?


#5

Remove defaultscripts.js from running scripts. and any other script.
And load a new defaultscripts.js by searching for defaultscripts.js in the same running scripts window. But halfway the screen.

Ok, below this seems not valid for you, but already did type it :slight_smile:

  • Check if the entity is not LOCKED ! In the netities list you can see that easy.
  • Are you logged in ? Check it under menu -> file.
  • Do you really have the correct edit rights set on your domain for your avatar ?

Editting works normally pretty fine for mw with mouse and default edit.js


#6

Yes, I am logged in


@Richardus.Raymaker I cleared cache again, I stopped running scripts and loaded up a new default script. I can not click on Grid or Entity Properties. I went to Welcome and the same is true.

As you can see from the settings page, I appear to have all necessary permissions.


#7

Its -definitely- unintended behavior and something I havent seen for a very long time:

As the ultimate reset: Try removing the interface.ini at C:\Users\<username>\AppData\Roaming\High Fidelity\. Note this requires you to reapply your avatar and forces you to relog. It also clears all your script references and should there after behave as if a fresh installation, aside from any changes to client folder.


#8

Settings are stored in Interface.json now rather than in Interface.ini. File is in the same location.


#9

Also, the old interface.ini was not removed, so it is easy to miss the live interface.json file at the bottom of the list.


#10

Thanks @Balpien.Hammerer and @ctrlaltdavid et al. I’ll try this when I get home this evening. I assume I just delete the file and interface will re-write it?


#11

Yes, it will. BTW, I went to equus, created a box, edit it, moved it around, changed its size, deleted it, etc. All OK. I did this with the default edit.js


#12

No good. I deleted interface.json but my behavior is the same. It perhaps is possible that it’s on my sandbox which is on a remote computer with great bandwidth, however you had said you had no trouble in the domain. Perhaps I also need to delete interface.ini ?
I’ll mess with it again tomorrow.