Steam VR: Why are my controllers not working with Vive Trackers?


#1

As per an update less than 24 hours ago, Valve released an update to Steam VR (build 1538437695). In this, the trackers were changed in a dramatic way:

Vive Tracker:

  • Changed trackers to default to “held in hand” mode.

  • Fixed Vive Tracker support in Duck Season, Tactical AR, American Dream, Operation Warcade, and Arizona Sunshine.

The first bullet is a major concern: When you go to use your trackers, they will act like pseudo-hand controllers. This means jumping into High Fidelity can (and most of the time, will) result in the trackers taking the roles of your hand controllers (this also happens in VR Chat and anywhere else who uses the trackers for full body tracking). To make things tougher, the SteamVR Compositor will also treat them as hand controllers (though visually they’ll still be pucks) and as a result, your normal hand controllers will not work, which is a problem since you need to use the VR settings menu to fix the problem.

First, The Good Thing From All Of This

The pucks can now be assigned to various profiles and roles. In addition to “held in hand” mode, there are roles for left and right feet, waist, chest, shoulders, keyboard, and camera. This does mean that stuff like this is being looked into. (Can anyone say tracker support for the spectator camera for mixed reality videos?)

Too bad no one was expecting it and as a result, Valve assumed everyone was using them for Duck Season and the majority of other shooty games.

The Fix

The fix can be done in two ways:

Thanks to Scyntrus, you can follow this basic step by step process:

  1. Start Steam VR, put your headset on, and turn on your controllers.

    DO NOT TURN ON ALL YOUR TRACKERS. UNTIL YOU FIX THIS, TURNING A TRACKER ON WILL REPLACE ONE OF YOUR ACTUAL HAND CONTROLLERS!

  2. Bring up the Steam Overlay. If you can’t and you ignored my previous warning, take a look at your hand controllers (in VR). If the hand icons are missing at the bottom, then your trackers have overridden your hand controllers and you will have to restart SteamVR.
  3. Open up Settings and go to Controller Binding.
  4. Select any app from the list (may be best to start with the VR Compositor).
  5. Under Current Controller, change this from “Vive Controller” to “Vive Tracker in Hand.”
  6. Select Managed Trackers.
  7. You should see one (or more) of your trackers. For each one, change their Role from “Held in Hand” to anything else (I haven’t fully dabbled with “Disabled”, so your results may vary with that one). If you strictly use your Trackers for full body, you can assign each tracker their correct role.

The Controller Settings menu may crash and turn black (personally experienced the latter). If this happens, you will have to restart SteamVR. Changing these settings applies to all VR applications.

A tip for those who may have a large number of trackers to change, thanks to a major tip from Steam user Elum:

  1. Start SteamVR and turn on ALL your trackers. Hand controllers are totally optional.
  2. Open up your favorite web browser and go to: http://127.0.0.1:8998/dashboard/controllerbinding.html
  3. Follow the above guide, starting from step 4, using your web browser.
  4. Restart SteamVR and enjoy!

What I Have Found Works So Far

  1. After doing one of the above, start Steam VR and turn your hand controllers on. Give them a few squeezes and check that you can still bring up the menus.
  2. One at a time, turn the trackers on, and after each one, keep checking your controllers and accessing the menu (with each controller). If you have a controller not cooperating, restart the process.
  3. Repeat until all trackers are on.
  4. Question what was Valve thinking with this decision.

Links Regarding This Update



#2

I ran into this exact problem yesterday :nauseated_face:
My fix was the following:

  1. In the weeks before I steadily ignored SteamVR’s directive to bind the trackers/controllers for HiFi - luckily not having fixed a running system did the trick here.

  2. Yesterday, I was forced to update the controllers’ firmware as they wouldn’t work without it.
    The trackers are still running on their old firmware.

  3. When I only got either the controllers or the trackers running in HiFi (but never controllers and trackers at the same time) I restarted my whole system.

  4. I fired up SteamVR & the controllers, but not the trackers.

  5. Only after making the controllers work in HiFi, I powered up the trackers.

Controllers and trackers worked fine like this - I hope I can reproduce this tonight :purple_heart: :sunglasses:


#3

Thank you for this - accessing the settings via a web browser makes it way easier!


#4

I F****** called it!

Instead of warning people ahead of time to maybe recommend the correct mode of the trackers, they appealed to the majority of games and not the majority of uses and did so without telling anyone.

I’m not saying the idea of it is wrong, far from. It does mean that, in theory, High Fidelity could FINALLY surpass the mystical 5 tracker limit (by assigning 2 trackers as hand controllers) and ideas like custom VR controllers can be even more of a thing (custom gloves with a floating joypad, anyone?).

But forcing all users to redefine it? Yeah… not the brightest move, Valve.