SteamVR get always started, also when user did not set steam todo that


#1

Interface.exe have a big hugh long standing bug and i think the devs did know that for a long time. Since a few weeks ago i know why i always did have audio problems.

See this thread on how to disable in steamVR the functionalit.

The big problem and bug is that interface.exe is ignoring that setting complete. and making a choas on your system. Especially with your sound settings. Normally you set steamVR so it use your HMD sound card and microphone. But you not want that in desktop mode. But as soon interface is starting, its strating against what the user did config steamVR.

Screwed audio playback device etc. !
And a new problem, because steamVR is not running so you start it. But steamVR cannot update because high fidlity hijacked steamVR and never closed it when you close interfece.exe besides it’s aleready a bug that it’s starting steamVR.

Anyway, if you did run high fidelity before you did run steamVR. because you where in hifi desktop mode. And then start steamVR, it cannot update.

This error is fully to blame at high fidelity and interface that did run steamVR.

DO NOT START SteamVR at boot.
Just check if steamVR is running, if not disable the HMD parts in interface.exe. Thats the correct implementation. Not run steam against users will and then let the user figure out how to end the tasks (VR Compositor and VR dashboard need to be killed manual) You also need to kill them manual after every use of interface.

And because this bug you not use VR voice anymore because steamVR need to be set to the correct playback device. But that makes you lose audio in VR.


#2

I just proof that High Fidleiity not need steamVR started.
I did a simple test aftewr a clean system startup.

  • Rename the vivesetup directory.
  • Then start High Fidelity, it’s starting faster to !

High fidelity does not detect the HMD then, perfect. Because i did not start steamVR.
So this is really a bug and unwanted wrong implementation. You not go start steamVR hidden. You follow the settings from steamVR or just checxk if steamVR have processes running. If not. just handle it as a system without HMD.

Somebody made a wrong decision by thinking it nmeed to be started always.


#3

I just used high fideity in desktop mode. already powred my VR headset. Yes it’s not powered normally because implementation is bad in software and start steamVR many times, when you not want it.

Am pretty sure high fidelity fixed this bug in the past and steamVR got not started. Hope this bug get fast fixed again. because one reason to use high fidelity more is because it did not start steamVR !

Why is it back ?
Why is steamVR starting hidden secret in the background while i told steamVR not to start with the application.

The result is already a chaos on my system.
I start SteamVR when i need it. The result of the bug in high fidility is this. Am really disappointed that it’s back and create straight away problems. Not really motivating.

Now i need to kill steamVR manual and start steamVR how i do.

Solution, check if steamVR is started as application. if not ! do not start steamVR. Or just close steamVR on exit of high fidelity, because if it did start it

If this is checked in steamVR. do not use steamVR pluigins are start it hidden in the background.

image

Out of mood todo more right now with high fidleity, nasty bug is back.

ADD: did high fidelity mabye made soem command line parameter to disable the auto start ? I need to look for that. Still would be nice if it just not do it default.

Oops there is.
–disable-inputs=“OpenVR (Vive)”

Now i can relax and jump in high fidelity