Still problems with collision hulls *Static Mesh* Beta 15


#1

As I mentioned in the comments to Beta release 14:

https://forums.highfidelity.com/t/beta-release-14-comments/11046/25

I still have the same problem with Static Mesh. I want say, I love this and I am very grateful for this feature @leviathan, but it is not permanently working for me. If I upload a model, and choose ‘Static Mesh’, everything is fine. If I teleport somewhere and come back, or if I login later, the collison hullls seems to poof away (and I can’t make them visible in general. The menu Developer>Physics>Collision Hulls don’t show this Static Mesh hulls for me).


#2

Yeah, ive seen this happen as well with my skeeball prototype this morning. It feel as if either the orientation or the scale goes incorrect occasionally

Seems to occur on relog and especially when loading from cache


#3

Sounds like maybe there is a race condition that causes the ModelEntityItem to sometimes not be properly flagged for addition into the physics simulation. Here is something to try: when a “static-mesh” entity incorrectly loads (visible but no collision shape) try moving it’s position a little bit --> this will put the entity on a list of objects that need to be updated in the physics engine, and may trigger the shape to be built. If this is a valid workaround then it must be a race and I’ll have to find it.

Meanwhile, not the same bug but somewhat related…

(1) I think there is a bug where the existence of a non-empty string in the compoundShapeURL property when the shapeType is NOT set to “compound” can cause a problem where the model does not render when this menu option is enabled: Developer --> Physics --> Draw Collision Hulls. I have a fix for this one in an unfinished branch.

(2) Also, I’ve seen a problem where if a ModelEntityItem is given a bogus compoundShapeURL property (to a link that doesn’t exist) then the whole model might never render at all, which would also make it never collide. This needs to be fixed and I’m going to try to do so in one of the projects I’m working on but in the meantime for best results: clear out unused “compoundShapeURL” properties (e.g. when NOT using “compound” shapeType).


#4

@leviathan, done, but the collision hulls still away.

But I’ve figured out something. After I moved it a little and nothing happend, I’ve cleared the cache. The object move (visible) to position 0,0,0. After re-log, it was on the position where it should be, but the ‘Static Mesh’ in options changed to ‘None’. When selected ‘Static Mesh’, the collision hulls are back.

Sorry, guess it sounds strange, hopefully it helps a little.


#5

I can confirm this happened to me as well, I moved the incorrect statis mesh around, and then cleared the cache. Everything set to static spawned at 0,0,0 instead and still incorrect in shape.


#6

This probably got lost in another thread, so I’ll report it here:
The static mesh seems to disappear (or maybe gets relocated to 0/0/0) when the client is present in a domain and the domain is restarted. TPing away and back fixes that one.


#7

Unfortunately this don’t fix it for me. The object is still without an collision hull.


#8

Right, this was not a fix suggestion for your problem. I am just documenting other incorrect behaviors/clues to help locate the root cause(s).


#9

I see problems too with my terrain, First when i jumped in with the vive. the ground where phantom, only relog fixt that. Just replaced my terrain for updated one. The static mesh is gone or seems to be on other place. again only relog fixt the problem. The terrain is not have a bottom side.


#10

Which build of interface. I noted earlier that the more recent dev builds broke static mesh collision in odd ways. The builds that added hull per sub-assembly broke static mesh collision entirely.


#11

I’m running the PR 8260 - for me ‘static mesh’ is working more stable in this build as in the builds before. I just had this ‘phantom’ problem one time, everytime else it’s doing how it should.


#12

Using only beta builds, Build 5111


#13

Yes, use the beta builds, they are stable. Dev builds have sharp edges. I’m only on the dev builds to see if the reported bugs have been fixed and (more important) to see if new bugs have been created. Reporting these before they get pushed to a new beta is vital.