Strange errors , ATP loading stall. Objects not showing


#1

Just finished my latest mesh, upload it to asset server. Paste the URL. Empty cube. Looking in the domain server logs i see this error.

[DEBUG] [09/24 15:24:43] Requesting public key for user “Richardus.Raymaker”
[DEBUG] [09/24 15:24:43] Could not verify user “Richardus.Raymaker” as allowed editor. In the interim this user will be given edit rights to avoid a trashing of public key requests and connect requests.

Also the progress indicator is stalled, because it’;s trying to load the model with ATP. and the fbx file is only 1.5MB in size. Tried the object with the old http way that’s working fine.

After that i did use the url again, and then ATP is loading fine. Is there soem race condition with uploading to ATP and then try to load ity inworld when the object is not cached ?

Also my interface log get spammed with this. over and over.

[DEBUG] [09/24 15:30:50] ApplicationOverlay::renderOverlay() batch: Batch::CacheState[ commandsSize: 395 offsetsSize: 395 paramsSize: 644 dataSize: 3280 ]
[DEBUG] [09/24 15:30:50] ApplicationOverlay::renderOverlay() batch: Batch::CacheState[ commandsSize: 395 offsetsSize: 395 paramsSize: 644 dataSize: 3280 ]

Ok, this looping and looping and stalled AT{P download (and i removed just the object) crashed the interface. Build 3218

Faulting application name: interface.exe, version: 0.0.0.0, time stamp: 0x560375f3
Faulting module name: Qt5Core.dll, version: 5.4.1.0, time stamp: 0x54e2d7b9
Exception code: 0xc0000005
Fault offset: 0x00001814
Faulting process ID: 0x2720
Faulting application start time: 0x01d0f6cd5eac49c5
Report ID: 29ae27b8-ccff-4e2f-9794-af19c2fa7b9a
Faulting package full name:
Faulting package-relative application ID:

ADD: i just deleted manual all cache from the disk. and tried to load the URL from ATP, the download is stall again. after a relog the object the indicator is still frozen.


#2

Another STall with my collision shape on ATP. So i decided to wipe cache from interface. At the moment i clicked that option. Interface decided to crash :wink:

Faulting application name: interface.exe, version: 0.0.0.0, time stamp: 0x560428cd
Faulting module name: Qt5Core.dll, version: 5.4.1.0, time stamp: 0x54e2d7b9
Exception code: 0xc0000005
Fault offset: 0x0019406d
Faulting process ID: 0x24fc
Faulting application start time: 0x01d0f6fc4797a96a
Report ID: 4ff05d4c-2743-49ef-9170-ed528bcfc9a2
Faulting package full name:
Faulting package-relative application ID:

After that and restarting interface the collision shape seems to load. I will see this problems a few times more i think until it’s fixt. need to fix soem errors in the collision shape.


#3

Hi @Richardus.Raymaker can you try and keep the ATP posts in this thread https://alphas.highfidelity.io/t/asset-transfer-protocol-this-is-whats-coming/7103/32