Strange rendering


#1

Isnt anybody going to say anything about the completely different rendering with the latest builds?
I know I am not the only one experiencing this.
Can someone in the know please advise what the new settings should be and does this mean I have to rebuild my models?


#2

This seems related to HiFi no longer being happy with non power of 2 sized images. Previously it was fairly lax about this - now it seems to want POT compliant images. Will reference this in worklist - if it’s not a bug then end users should be 1) warned of such a change and 2) disallowed rendering the asset if the engine won’t render it properly and warned. @chris

https://worklist.net/20288


#3

I am trying to test this but the interface is so unstable that I cant do a thing.
I changed one to 512 x 512 and that had no effect.
I am not about to change anything until I get official ruling from hifi, it could be just a bug.
Giving up for today in frustration.


#4

It is frustrating, I’m building a set of example models to illustrate the specific case I found where changing one of your images from 550x550 to 512x512 made it work, but, I may have jumped the gun since I just tried a 700x700 and it did work. I’m trying to find if it’s power of 2 or something else about your grass (damn I just realized the irony of talking POT and grass) that leads to failure.


#5

So here’s my finding - Adrian has a grass texture it’s jpeg at 550 x 550. It will not render. Resize it to 512x512 and it renders fine.

I have a tile floor texture - it came as 700x700. It renders fine at 700x700 and after scaling to 512x512 works fine, but, get this… scale it to 550x550 and it fails to render.

http://omegaheron.ddns.net/content/heronpark/tiletest4.fbx

http://omegaheron.ddns.net/content/heronpark/tiletest3.fbx

Tile test 4 has an image at 550x500 whilst Tile test 3 has one at 700 x 700.

It’s same image, simply rescaled.


#6

So strange. Give the same texture - resize it to 550x550, 600x600, 650x650 place each on something. Only the 600x600 works. So… does it have to be power of two or some even hundred number? This one is making my head spin.

Left to right - same image applied to a cube in blender. 550x500, 600x600, 650x650 source resolutions.


#7

With windows version 1833 all three cubes show texture.

1833 shows

Sorry for the black on black photo - that is same model - look closely at the left/right of green.


#8

I really appreciate your efforts here @OmegaHeron but I would really like an official hifi answer here before I spend the next week changing all my textures over just to hear zappoman say “we fixed the issue”

Is this an issue?
Is this being worked on?
or is this what we now have to live with?
Please all I ask for is some direction.
Thank you


#9

Hi,

@OmegaHeron and @Adrian . It is a bug and I have sent it all over to @sam who is making a lot of rendering changes right now.


#10

Thank you @chris thats all I needed to know.


#11

Wasn’t an issue for me, just was chasing the bug. I tend to stick to power of two sized textures for many reasons, but was an interesting puzzle to work out.


#12

And - can confirm fixed as of 1845 Windows build. Test model made with various non power of two sized textures displays proper.


#13

@OmegaHeron what are your reasons for sticking with power of two sizes?
Is it true that they render faster?


#14

@Adrian - it’s more efficient to move data at powers of two, and - to some extent all image data is changed somewhat to fit in that space improving efficiency. It probably saves a little time not having to do any tricks on non power of two images - and in a very complex scene might add up to enough to make a difference.

Blender loves powers of two sizes. If baking final textures using diffuse texture basis - it can speed it up a lot having all your base textures POT, again in a complex scene. I have some with several hundred textures between diffuse, normal, specular and bump sources… those show how much it matters.

In the grand scheme of things it’s probably not worth re-creating tons of images to POT sizes, but, moving forward… it’s good stuff. The most difficult thing is most of the time you end up scaling down vs up. I’d take a 900x900 to 1024x1024, but a 700x700 down to 512x512. Of course if you’re making a seamless texture… then it’s all good - go down and tile to get back to 1K.