Strange texture problem. hifi is changing parameters?


Ok, finaly could test my new build before i make the collision shape.

It looks perfect in blender.

But in high fidelity we get a Boo Boo,

Now, what is wrong ?
I use for east and west one materials and for north and south a seperate materials. If i do not do that, thing’s get not unwraped correctly with the super most used Unwrap -> cube projection. really suggest to use that, because align textures you can do sleeping.

Until you hit the above problem.


The issue reminds me of the texture/material name issue that occasionally can be accidentally left, which causes material asignment and UV maps to be forgotten when read by HiFi. Have you made sure all the textures and material names do not contain . ?

If not, make sure you have the correct UVMap selected when exporting from Blender. Remember however Generated Texture positions do not work as well in engines as UV maps do.


Genrated textures not saying me muchj. i just generate UV-map by selection the best option to create it. in this case ‘cubic projection’ rocks. and then just adjust it with the size parameter.

It’s the onlky correct way to work with textures and get things easy aligned. If it’s failing in hifi partly. Sofar it worked always. it need to be fixt soon. Everything face have a destination on UV-Map.

Texture and Map names i use without (.) dot But the dot seems not a problem anymore. unless the placed a bug back. Besides, it seems to work fine on the other wall side. it’s just one direction that’s going wrong.


Yeah the size parameters are something that are no translated when exported into FBX. It becomes 1,1,1.

Youll have to do the scaling in the UV Editor instead in the texture setting by selecting the faces (in the UV Editor) that have the material applied and then scale to there.


NMo, complete wrong, the get transferred to the FBX and used. Because i use it for a long time on many parts. like the inside wall you see. and it’s working perfect on other parts. only not on one direction.

just done a test on cube. and that works fine. Hmm, then why it’s going wrong on blender. It did al go wrong from the begin that is why i did use a second material to correct blender’s weirdness.

It’s just the side that need a differenbt pretty high Size setting to get things right. compared to the other side. The wrong material side is 9000,50 to get the same brick with perfect alignment. the other use 10,50. It’s still possible HiFi is not rerading the 9000,50 correct. and also still not sure why one side need a high number like that.

Lets call it blender complexity weirdness.

Aligning with UV-Maps is impossible mission in blender. When you use cubic projection it’s doing doing everything perfect in easy way. if you need to unwrap a part again later it’s fine aligned without screwing everything. If you get it aligned correctly at all.

I need to retest the cubic unwrapping on the object again. mesh is very easy to make mess.

ADD: Mabye there’s a change that high fidelity is only using the offset for wall material one and use that for wall m,aterial 2 also. because in blender i see the same behvior then. That would be a bug in high fidelity ?! All other textures are fine.

Gna, wait a second. i think high fideity mabye is chocking on the space in the material name. Forgot the underscore, so i can test that first. And that woudl explain possible why it’s using only the first one. Still call that a bug in hifi too.

Well, that’s not the solution and problem. still going wrong.
Just see other wall texture at the same side is also going wrong. It’s the X face side that gives problems.


You have to remember: the render view is different by default from how it is actually on the UV map It wont preview correctly as it would when exported.

Using the Generated Material Texture settings is not the right way to preview the textures, You have to use the UV Textures instead.

After you select the UV, and select the proper UV Map, the mapping in the Blender preview will appear the same way as it does in High Fidelity. Because Generated Coordinates are not exported. Instead it is using the UV map you generated.

This is because if you use cube mapping, it will map each side of the mesh full to 1:1 to the texture depending on the largest surface you have for that direction. It will not scale it.

Easiest method is to use the selection tool and manually selecting each major axis side and then applying a projection map. Only down side is that you have to get the seams down for the corners.


I do not use generated. here are my settings. i see that the Y direction is screwed also.
It all looks fine and perfect in blender materials few , not in high fidelity.

here is the setting i use.
Always using UV , Flat. that’s the default in blender.

So only the Z faces are fine in my build with cubic projection. the Z and X faces view the texture wrong. I need to dig a bit more in it later. Still expect something else wrong.

ADD: Overlooked it, you use UVmap in the center. Need to test that. Tested UVmap set or not set is no difference.


Could you send me the file and I can check what exactly is wrong with it? so I can tell you exactly how to fix it.


Give me a minute, sending the url to you in PM. and mabye it’s not fixable by one of us.


Ok I looked through the file. One of the other things that might be affecting is the World Axis conversion. If you use the Repetitions, of them you probably always have to make sure to convert your texture axises to XZY or in the similar. I dont use them, so harder for me to say the precise values you should be using there.

This is why it is simpler simply to scale the UV map components, instead of using repetitions. This always may have caused the issue that some of the materials (you have 3 brick materials) worked to some degree but were not exact. It is very likely, that forexample the stretched face simply had its width set to 1, when it was supposed to be 50.

I still suggest simply scale down everything to 1, and then modify the the UV map instead with tiled textures turned on (Left Menu in UV editor, Coordinates-> Repeat), and scaling all the parts by 5 or so., so that you do not have to mess about these values.


As soon i found this option (Left Menu in UV editor, Coordinates-> Repeat) i could look into it. Problem is, that right now i do not see that option anywhere. do you have a screen capture ? Btw, what left menu ? never seen one in blender in the uv editor.

I do use 3 brick materials, because it’s pretty impossible to get it easy right with one materials. it’s better to use 34 so you not screw up things when you change something. I need to work that out later.

ADD: Found the repeat. it’s under texture -> image mapping. That repeat is not doing anything at all. or i use the wrong one. or a switch need to be set. but no luck sofar.

If you mean this:

That’s not working at all, nothing happens when you change the repeat. Only Size works sofar.


Selecting face by face helps to get lower number in the size setting 2.0 , 2.0. Looks perfect in blender. But it’s still wonky in HiFi and Unity. ANd not understand why the other side is going perfect !

ADD 2015-11-05:

Coo Coo :stuck_out_tongue:
Something really weird happend in my build, afraid i can dump all the work and start over from scratch. Unless we know what happend.

Did a normal Smart uv unwrap, aligned the textures. So the face at the right side is uv-unwrapped. The face left is still cubic projection.

Looks both fine in blender.

Now in the Autodesk FBX viewer i know cubic projection is showing wrong. The smart unwrap is showing fine.

And what is High Fidelity doing.

But, Unity is doing the same.

I hope i can use unity as reference. Or mabye trust the autodesk fbx viewer. You anyway never get the same result in 3 different programs.

And i have replaced the right face for a new one before i did this test.


Now the intressting part, i decided to test the orginal blender file, the above examples where exported fbx i worked with. It looks like the blender FBX exporter is corrupting something. Or something else good wrong.

So, need to change the workflow a little bit. To keep this usable. and fix error problems again.


i think im having the same problems.