Streaming Audio in highfidelity


We need a good way to play music in hifi, we use to have one but none of us could get it to work yesterday.
It needs to be a solution that everyone can use cos thats more fun.
In second life people use Shoutcast to stream which is poor quality but works ok once you can figure out the ips and ports and stuff
We had that working for a while in hifi but yesterday it proved to be good and broken.
Caitlyn and Chris had to step in to save the day buying virtual audio cable to hack a method to use the voice channel.

The voice channel isnt a bad solution , its capable of good quality sound just the process of getting audio into it is really tricky.
What I would like is to be able to select as any input device like I select the mic to be able to select say itunes or any media player and connect that to the voice channel then assign the voice channel to a zone.
Maybe it could be a feature in the server?

I don’t know whats possible

QDeclarativeAudio Not Functional Windows 10

Remember yesterday when you asked if I tested this? “This” being the .qml file? The .qml file that I proved was playing Kevin’s stream that I reversed into my mic and piped back in?

I want to know why?

How is it only possible that it works on my machine and no one else?

If I had known that ahead time, it wouldn’t have been a last minute scramble. Am I wasting my time? Should I just take a break like so many others? It was stressful and (at times) frantic for me doing something that (in the end) is supposed to be fun.

The last 36 hours were not fun for me

It’s nearing 6am and I’m just wondering why I didn’t ask around for more testing. I tested the qml file with the stream that plays @Music and other people told me it was working. Pretty sure that was Kevin, but it was a few weeks ago. That’s when I stopped working on it. I figured, “ok, no problem. I’ll just swap his stream in, and we’re good to go.” Never had it crossed my mind that ONLY specific streams will work ONLY for specific computers.

The little shit here and there starts to break ya down

I’ve been a forever optimist about this place but even I have my limits. The physics hull I labored over for months is undergoing improvements due to the optomize engine. Good. But I still walk around like I’m on ice. No friction. What’s going on there? Why is that still a problem? I started making a bowling game, and quit because when I walk forward it’s too slipper (even for a BOWLING ALLEY) :smiley:

Kudos to the good 'ol _STACK_MANAGER_0

That machine as under-spec’d as it is, was able support 24 avatars and didn’t skip a beat! This has me remaining optimistic about the future of High Fi. I’ll throw additional machine(s) at it next time using the methods already laid out by @b and his network team.

I have a lot more research I have to do; and testing as well, before I’ll be comfortable rolling an event like that again. Stream seems like cheating when you have such good audio capabilities built-in. I don’t WANT SL2. I WANT to have 3D specialized audio. We have that here. Let’s start using it.


It was a great night but a solution needs to be really really easy to use
ie select itunes in hifi press play in itunes.
The stack manger is a server, we don’t need more servers we need to exploit the one we have


I’m going to update the Stream QML and JS so that you can input whatever URL you want. I need vindication on my efforts. Standby…


I’ve got it finished.

YouTube video upload in progress.

In the meantime, here is how you use it:

Don’t mess that part up.

You have a “Reveal Scripts Folder” on the “Running Scripts” QML overlay. Find your system folder within…

“C:\Program Files\High Fidelity\scripts\system”


You simply run script “From Disk” and choose the .js file you just downloaded.

The other helper files are online and easy to snatch… I mean borrow for later. :wink: and are hosted on just check your logs.

Anyway, it will default to a radio station. You MUST click Pause, then update the input box with a stream, then click PLAY. It will take your new stream ((IF IT IS VALID!!!))

If you don’t like the style, or you don’t like the positioning; stay patient this is a stop-gap.

Or, since you have the whole kit and kaboodle now, just mod it yourself. I’m going outside for awhile.

Known functional streams ((remove whitespace prior to paste)):
h t t p : / / s;stream.nsv&type=mp3&volume=70&autostart=true
h t t p : / / s

I can’t WAIT for someone to come to me and tell me it doesn’t work. TOTALLY looking forward to that confrontation… :smiley: Hopefully, this stream kit will enable people to determine what works and what doesn’t. If the default stream doesn’t sound for you, then yes, Houston we have a problem. So someone please at least ((for my sanity)) replicate my work and let me know it’s functional. I need this you guys. I really do.




Nooooooooo! Lol.

I added new logging. What do your logs say? Probably just invalid source. Idk. I really don’t. But hey, looks like I’ve got a monopoly on streaming into hifi. Lol


Try removing the end of the url.end it with just 8080
And did the default station play? I must know! :slight_smile:


Also grab the k-lite codec pack. It’s free. Maybe that is the problem…


I got nothing b4 I put in the URL nothing after with the one you supplied and nothing from my stream



All the URLs work in other places browsers so etc so I must have the codec


Then it’s settled. I’m a WIZARD. fml.


If only there was a 3 Rd person in HF who could check this


Unfortunately I am getting the same as Judas.
I tried a url which is working otherwise.
The default station didn’t play for me.


I just tried it and I get music stream but no boombox control overlay. I don’t see any errors in log but I will mess with it more.


are you on windows 7?


yes, Win 7 64 on this machine


thats a small pattern then u and alpha are both on windows 7, thats strange didn’t you get the update?
With Windows 10 Microsoft have made changes to media streaming DLNA/UPnP features of Windows


Can’t get it to work either.
Got a lot of stuff in the log which i copied to this textfile.

Maybe that helps.