Suggestion for quick fix around SteamVR startup


#1

I got idea. It must be easy to implement. It’s a quick fix until a better one comes.

Can high fidelity not add a parameter to the startup line. One that let you disable HMD so high fidelity is running like it’s not connected to a system with HMD.

With the parameter option it’s just matter of heaving 2 shortcuts. one with the parameter that disable the HMD functionality and a normal shortcut for the times you need HMD.

Sounds the most simple and quick solution. You only need to block loading of steamVR things in the code. That would the same then as renaming the vivesetup directory.


Beta Release 42
#2

Hi @Richardus.Raymaker,

There is already such a command line parameter:
--disable-inputs="OpenVR (Vive)"

If you pass that to Interface, it will not load the Vive input plugin and SteamVR won’t start.
NOTE: The Vive input plugin will be disabled for the entire run, you’ll have to restart to use it.


SteamVR get always started, also when user did not set steam todo that
#3

Thanks
That’s anormal action here anyway. i always did quite Hifi to acivate HMD, because steamvr where not running. Going to try that parameter !

ADD: Wish that somebody told this 6 months ago. would fixed so many problems.