The collision shape is somehwere - just not where the object is


#1

Hello, the collision is - when exported as .fbx (from blender) - somewhere, just not where the object is. Not sure what I do wrong… any ideas?


#2

Under entity properties look for reset to natural dimentions


#3

Heya!

Couple of pointers when creating collision shapes:

  1. Reset natural dimensions
  2. Make sure the origin, rotation and dimensions for both of the objects is the same: this is quite important :slight_smile:
  3. Make sure each part of the collision mesh hull is convex. Usually this means keeping parts separate to create holes.

#4

Got it, thanks Judas and Menithal :slight_smile:

Blender export, there is a ‘forward’ and ‘up’ option for the FBX export. It was Up: -Y by default. Changed it to Z and -X forward, and it works.