Trouble with 5081


#1

The assignment client is spamming:

[06/29 06:34:32] [WARNING] [53454] ;assignment-client] Could not attach to shared memory at key “domain-server.local-port”
[06/20 06:37:49] [WARNING] [53454] [assignment-client] Failed to read local assignment server port from shared memory - will send assignment request to previous assignment server socket.

I am asking that they reinstall it on their end in case I have done something wrong, however,. I followed the same procedure as previously. I downloaded the client. Stopped the server. Placed the update into Applications. ran the update and the log begins to spam. The Domain Server tab is pasted below.

The build is current. I can go to Playa but can not go “HOME” by selecting it from the server menu or get there from within interface by typing localhost in the address bar and my domain remains inaccessible.

Locally everything works fine. I can go to other places fine, I can go to the local host sandbox which is helpful since I’m working on animations, I just can’t get to my hosted domain Equus. Here follows the Domain Server tab contents:

hifi.embeddedwebserver: Attempting to bind TCP socket on port "40100"
hifi.embeddedwebserver: TCP socket is listening on QHostAddress(“0.0.0.0”) and port 40100
Time zone: CDT
[06/28 23:53:47] [DEBUG] Settings thread started.
[06/28 23:53:47] [DEBUG] Setting up domain-server
[06/28 23:53:47] [DEBUG] Reading JSON config file at “/Users/josh/Library/Application Support/High Fidelity/domain-server/config.json”
[06/28 23:53:47] [DEBUG] --------------- permissions ---------------------
[06/28 23:53:47] [DEBUG] “localhost” [permissions: “localhost” – connect locks rez rez-tmp asset-server ignore-max-cap]
[06/28 23:53:47] [DEBUG] “logged-in” [permissions: “logged-in” – connect rez-tmp]
[06/28 23:53:47] [DEBUG] “anonymous” [permissions: “anonymous” – connect]
[06/28 23:53:47] [DEBUG] “horsche” [permissions: “horsche” – connect locks rez rez-tmp asset-server ignore-max-cap]
[06/28 23:53:47] [DEBUG] AccountManager URL for authenticated requests has been changed to https://metaverse.highfidelity.com
[06/28 23:53:47] [DEBUG] Found metaverse API account information for https://metaverse.highfidelity.com
[06/28 23:53:47] [DEBUG] Inserting assignment UUID: {c72161f1-74ba-42ea-acb6-11722a31e41d}, Type: 0 to static assignment hash.
[06/28 23:53:47] [DEBUG] Inserting assignment UUID: {28e257d7-5057-4e3a-9d81-ce33fcbdd6dd}, Type: 1 to static assignment hash.
[06/28 23:53:47] [DEBUG] Inserting assignment UUID: {2033c28f-df1e-4517-a467-52eeb3240ab1}, Type: 3 to static assignment hash.
[06/28 23:53:47] [DEBUG] Inserting assignment UUID: {ab20e730-93ce-43ce-bb95-7c24a4596168}, Type: 4 to static assignment hash.
[06/28 23:53:47] [DEBUG] Inserting assignment UUID: {d3e6db84-ac54-4dc8-938e-7230032cd3f0}, Type: 6 to static assignment hash.
[06/28 23:53:47] [DEBUG] Adding 1 of persistent script at URL “atp:/acScripts/ACAudioSearchAndInject.js” - pool “”
[06/28 23:53:47] [DEBUG] Inserting assignment UUID: {412b335d-4a5c-4b4c-b936-2e0d425df564}, Type: 2 to static assignment hash.
[06/28 23:53:47] [DEBUG] Adding 1 of persistent script at URL “http://ctrlaltstudio.com/downloads/hifi/scripts/nametags.js” - pool “”
[06/28 23:53:47] [DEBUG] Inserting assignment UUID: {459462be-0c6d-4d03-af0c-8a52f35a91dc}, Type: 2 to static assignment hash.
[06/28 23:53:47] [DEBUG] Adding 1 of persistent script at URL “http://ctrlaltstudio.com/downloads/hifi/scripts/chat.js” - pool “”
[06/28 23:53:47] [DEBUG] Inserting assignment UUID: {8594d5ee-1dc5-48e2-a50b-f2a3127edaf9}, Type: 2 to static assignment hash.
[06/28 23:53:47] [DEBUG] Adding 1 of persistent script at URL “http://ctrlaltstudio.com/downloads/hifi/scripts/inspect.js” - pool “”
[06/28 23:53:47] [DEBUG] Inserting assignment UUID: {da6219f2-0570-4ff2-83f3-540ff5f00e39}, Type: 2 to static assignment hash.
[06/28 23:53:47] [DEBUG] Adding 1 of persistent script at URL “http://ctrlaltstudio.com/downloads/hifi/scripts/edit.js” - pool “”
[06/28 23:53:47] [DEBUG] Inserting assignment UUID: {b69a16f3-1c5a-4c19-8d48-f0d4ba2b6a9e}, Type: 2 to static assignment hash.
[06/28 23:53:47] [DEBUG] Asynchronously looking up IP address for hostname “stun.highfidelity.io” - lookup ID is 1
[06/28 23:53:47] [DEBUG] Changed socket “send” buffer size from 9216 to 1048576 bytes
[06/28 23:53:47] [DEBUG] Changed socket “receive” buffer size from 196724 to 1048576 bytes
[06/28 23:53:47] [DEBUG] NodeList socket is listening on 40102
[06/28 23:53:47] [INFO] Local socket is 108.201.30.233:40102
[06/28 23:53:47] [DEBUG] Wrote local listening port 40102 to shared memory at key “domain-server.local-port”
[06/28 23:53:47] [DEBUG] Wrote local listening port 40100 to shared memory at key “domain-server.local-http-port”
[06/28 23:53:47] [DEBUG] Wrote local listening port 40101 to shared memory at key “domain-server.local-https-port”
[06/28 23:53:47] [DEBUG] NodeList UUID changed from “00000000-0000-0000-0000-000000000000” to “534853fb-7ef9-4fce-a158-0dcbbbc0e151”
[06/28 23:53:47] [DEBUG] Registering a packet listener for packet list type 14 (RequestAssignment)
[06/28 23:53:47] [DEBUG] Registering a packet listener for packet list type 13 (DomainListRequest)
[06/28 23:53:47] [DEBUG] Registering a packet listener for packet list type 19 (DomainServerPathQuery)
[06/28 23:53:47] [DEBUG] Registering a packet listener for packet list type 33 (NodeJsonStats)
[06/28 23:53:47] [DEBUG] Registering a packet listener for packet list type 55 (DomainDisconnectRequest)
[06/28 23:53:47] [DEBUG] Registering a packet listener for packet list type 47 (DomainSettingsRequest)
[06/28 23:53:47] [DEBUG] Registering a packet listener for packet list type 31 (DomainConnectRequest)
[06/28 23:53:47] [DEBUG] Registering a packet listener for packet list type 39 (ICEPing)
[06/28 23:53:47] [DEBUG] Registering a packet listener for packet list type 40 (ICEPingReply)
[06/28 23:53:47] [DEBUG] Registering a packet listener for packet list type 22 (ICEServerPeerInformation)
[06/28 23:53:47] [DEBUG] Registering a packet listener for packet list type 60 (ICEServerHeartbeatDenied)
[06/28 23:53:47] [DEBUG] Registering a packet listener for packet list type 63 (ICEServerHeartbeatACK)
[06/28 23:53:47] [DEBUG] Reset UUID for assignment - UUID: {39358a76-d9f1-42b7-b25c-88157250484f}, Type: 0 - and added to queue. Old UUID was “c72161f1-74ba-42ea-acb6-11722a31e41d”
[06/28 23:53:47] [DEBUG] Reset UUID for assignment - UUID: {87d27dd1-268f-4b20-8208-719bcd7a7a61}, Type: 1 - and added to queue. Old UUID was “28e257d7-5057-4e3a-9d81-ce33fcbdd6dd”
[06/28 23:53:47] [DEBUG] Reset UUID for assignment - UUID: {3d66be4f-cbf0-4048-a370-5c95c8201979}, Type: 3 - and added to queue. Old UUID was “2033c28f-df1e-4517-a467-52eeb3240ab1”
[06/28 23:53:47] [DEBUG] Reset UUID for assignment - UUID: {8a4e3541-8e9d-4dd1-ac8d-fa52b4e1865b}, Type: 4 - and added to queue. Old UUID was “ab20e730-93ce-43ce-bb95-7c24a4596168”
[06/28 23:53:47] [DEBUG] Reset UUID for assignment - UUID: {665d25eb-35d0-4036-ab4f-50292914e3fe}, Type: 6 - and added to queue. Old UUID was “d3e6db84-ac54-4dc8-938e-7230032cd3f0”
[06/28 23:53:47] [DEBUG] Reset UUID for assignment - UUID: {1be6a75f-c069-4590-9de4-add4980e27f6}, Type: 2 - and added to queue. Old UUID was “412b335d-4a5c-4b4c-b936-2e0d425df564”
[06/28 23:53:47] [DEBUG] Reset UUID for assignment - UUID: {79f8ddea-948b-41a8-970d-fd358603e3b6}, Type: 2 - and added to queue. Old UUID was “da6219f2-0570-4ff2-83f3-540ff5f00e39”
[06/28 23:53:47] [DEBUG] Reset UUID for assignment - UUID: {78203f44-2002-445c-ad9a-0030cf6f4836}, Type: 2 - and added to queue. Old UUID was “8594d5ee-1dc5-48e2-a50b-f2a3127edaf9”
[06/28 23:53:47] [DEBUG] Reset UUID for assignment - UUID: {d68b56e5-285b-41bc-b9a3-e6a8a541d699}, Type: 2 - and added to queue. Old UUID was “459462be-0c6d-4d03-af0c-8a52f35a91dc”
[06/28 23:53:47] [DEBUG] Reset UUID for assignment - UUID: {c68077f5-9586-40af-800f-e40baf20e19e}, Type: 2 - and added to queue. Old UUID was “b69a16f3-1c5a-4c19-8d48-f0d4ba2b6a9e”
[06/28 23:53:47] [DEBUG] Updating automatic networking setting in domain-server to “”
[06/28 23:53:47] [DEBUG] Setting new AccountManager OAuth token. F2C: “83” L2C: “73”
[06/28 23:53:47] [DEBUG] Persisting AccountManager accounts to “/Users/josh/Library/Application Support/High Fidelity/domain-server/AccountInfo.bin”
[06/28 23:53:47] [DEBUG] Clearing current private key in DataServerAccountInfo
[06/28 23:53:47] [DEBUG] Starting worker thread to generate 2048-bit RSA keypair.
[06/28 23:53:47] [DEBUG] Not sending ice-server heartbeat since there is no selected ice-server.
[06/28 23:53:47] [DEBUG] Waiting for “ice.highfidelity.com” host lookup response
[06/28 23:53:47] [DEBUG] domain-server “full” automatic networking enabled for ID “534853fb-7ef9-4fce-a158-0dcbbbc0e151” via “https://metaverse.highfidelity.com
[06/28 23:53:47] [INFO] Requesting temporary domain name
[06/28 23:53:47] [DEBUG] A domain ID is already present in domain-server settings: “534853fb-7ef9-4fce-a158-0dcbbbc0e151”
[06/28 23:53:47] [INFO] Abandoning request of temporary domain name.
[06/28 23:53:47] [DEBUG] Requesting public key for user “horsche”


#2

I just installed 5081 and my local sandbox server doesn’t work anymore either. Same logs in the assignment client.


#3

I’ve filed a bug - we will look at this ASAP!


#4

@Horsche and @petewall, I’m trying to reproduce the issue, but I can’t get any failures on my Windows 10 machine.

Can you tell me the specs of your machines, and how you are installing over any old versions (or if these are fresh installs)? Sorry this isn’t working right now - hopefully this will help to fix it more quickly.


#5

I have no trouble with my windows 10 client. The issue is occurring on a MAC which is running the server. I access that machine remotely. I can ask the site’s director for specifics as to that machine.


#6

My machine is a MacBook Pro (Retina, 15-inch, Late 2013), 2GHz, 16 GB, running 10.11.5.

If I recall, when I launched Sandbox, it prompted me to upgrade, which downloaded the new .dmg. Then I dragged the new .app files into the same High Fidelity folder in my Applications directory, which replaced the old .app files.


#7

I am receiving information on the mac machine. It is not being used as an end user machine but strictly as a server. The architecture is a dual quad core xenon 2.8GHZ, 4GB ram, GeForce gt640 I should have more information soon as to OS and other incidentals.


#8

Thanks @ZappoMan. I got a notification for a new build (5086) and installed that. It’s working much better. I am able to connect to my sandbox server again.

Now, this could be my (relatively) slower computer, but now it appears that the menu bar takes a very long time to respond. I’m talking about the OS X menu bar, not a UI widget inside of Interface. I click on a menu bar and it takes 10+ seconds to respond. Interface.app is only using about 20-30% CPU usage, and walking around in-world seems just as responsive as before. I don’t recall this happening before, but I’m not sure enough, so I haven’t started a new topic yet.


#9

Yes, same here @petewall it fixed the problem entirely and it’s nice to have Equus up and running again. I’ve not encountered the difficulty you’re mentioning but then the mac that supports my domain is a remote machine I access from forty miles away.