Ubuntu 16.04 (Xenial) Package


#5

Another Thank You! I’m running Ubuntu Studio 16.04.1. I am able to get into the interface though I have yet to try it out extensively. I have noticed that exiting the application does not properly end the process. Killing the process resulted in an error, eventually. I’m running the “stable” version. I’ll post more as I have time to test the builds.


#6

Glad it (mostly) works for you. The hang at exit of interface has been around a long time and, yes, it’s annoying. It will eventually core dump and close. Someday I hope to figure out why that’s happening and suggest a fix.


#7

RC34 (Build 6905) posted for Windows/Mac. See High Fidelity’s official Beta 34 posting for change lists/notes. Beta Release 34

Amazon is still being slow to serve some requests so I’m seeing build fails for stable RC34 and Unstable 6095. Once that sorts out I’ll post an update to availability.


#8

Stable RC34 and Unstable 6095 posted to repository.


#9

Stable RC35 and Unstable 6128 posted.

In case anyone ever wonders… for a specific point RC release, stable = unstable. Once unstable is > stable they diverge again. Trivia to fill in minimum reply length.


#10

Packages are currently broken for unstable and, if I allowed it to build, latest RC. Unfortunately, I’m on an extensive road trip for work and won’t be able to sort this out for several days. For now I’ve disabled building new unstable/stable packages. Problem is a new dependency that, unfortunately, exists in Ubuntu repository, but HiFi chose to refer to it as a new incompatible with Ubuntu’s thus requiring some work on my part to clean up I don’t have time for now.


#11

Is this what is cuasing the Domain Version Missmatch currenty? I didn’t read the whole threat before running the packages. I haven’t done this stuff in years so I’m super at a loss, thank you for putting the packages together i was able to finally get it running on my AWS Instance because of it, but can’t connect to it because of the version missmatch.


#12

Yes - it’s not up to date due to a change in dependency libraries for latest source. I will try fixing packages today and re-start auto building/pushing packages to repository, but, have extremely limited time at the moment and it’s a tedious set of changes to fix.


#13

Auto-build system is currently working its way through a considerable backlog of failed builds… sometime in next 2-3 hours packages should be up to date again for unstable.

Stable will not be up to date until RC39. Neither RC38 or RC38.1 (hotfix to 38) will build and I’m out of time to try to fix the mess in source for branches around code RC38/RC38.1 are based on.

Will advise when stable has been pushed, built and posted.


#14

I don’t think this will be a huge problem as few, if any, are actually using these packages other than myself… but, stable release 41 and unstable-6630 will be last builds posted until further notice. Machine that auto compiled all then posted to repository met an untimely death today. If I’m able to resurrect said machine or recover its custom autobuild system I may start posting again. But - no promises. Apologies if this impacts anyone.


#15

I’ve managed to rebuild compile system - unstable packages are back to current (Build 6659) and stable should be posting RC42.1 (Build 6658) sometime in next 30 minutes or so. Apologies for the downtime.


#16

Have I ever told you you’re my hero?

edit: still having an issue i think it’s user error but When i start the domain server and assignment client via ./domain-server && ./assignment-client -n 6

It queues up a bunch of stuff http://i.imgur.com/ufIUufR.png There’s a link to what it looks like, i’ve tried -n 10 ect as some people have suggested still nothing.


#17

Since DS seems to be working ok launch it however you like, but, alone as in ./domain-server&

Then launch AC with ./assignment-client -n6

Note No space for -n6

that doesn’t work try ./assignment-client -n6 -t7


#18

Oh god dammit, I need to sleep more. Thank you friend.


#19

Rumor mill has it that HiFi will be moving to QT5.9 sometime… In anticipation of this I’ve worked out methodology to do so for this package repository and have started building package linked against QT5.9. Once better tested I’ll post instructions for using QT5.9 packages and, eventually, migrate to using QT5.9 for default and deprecate QT5.6 builds.


#20

Use of Qt5.9 is imminent, it seems. So - to be ready please add the following PPA repository.

If you don’t – these packages will fail to install starting later this week when I stop compiling packages compiled against Qt5.6.

sudo add-apt-repository ppa:beineri/opt-qt59-xenial
sudo apt-get update

You do not need to do anything more than that – once default packages (stable and unstable types) start being built against 5.9 the first update/install of will pull what’s needed.

For more information about the PPA see;
https://launchpad.net/~beineri/+archive/ubuntu/opt-qt59-xenial

It’s also perfectly safe to have Qt5.6.x from currently used PPA and 5.9 from one you’re about to install in place at same time. They’re made to be isolated installs not impacting one another or system default QT libs.

If, and only if, nothing else uses Qt5.6.x from previous PPA you will get a notice saying it’s no longer needed and may be removed. Your choice – the 5.6 PPA does take up a fair bit of space. sudo apt-get autoremove will clean it up – though take caution to read what that command would remove – sometimes it can do dangerous things.


#21

Again - if you use these packages - be sure to add Qt5.9 PPA referenced in previous post. Today’s stable RC44 build (6716 RC44) will be last using Qt5.6.x – starting tomorrow 20/June unstable will require Qt5.9 PPA in place.


#22

RC45 (Build 6788) Posted – remember - you need to have added QT5.9 PPA or this (and unstable as well) will fail to install.

sudo add-apt-repository ppa:beineri/opt-qt59-xenial
sudo apt-get update

You do not need to do anything more than that – the first update/install of HF package will pull what’s needed.

For more information about the PPA see;
https://launchpad.net/~beineri/+archive/ubuntu/opt-qt59-xenial


#23

I’m currently updating these packages to use a better layout offering the following;
Interface only package
Stack (Sandbox) only package
Tools (vhacd-util and oven utilities that few, if any, even know about)
Daemon (systemd scripts for stack)

Once completed I’ll start a new thread and reference it from this one.


#24

New thread for new package layout at Updated Ubuntu Xenial Package