Unable to log in to server settings


#1

I was going through the docs of the server settings and came along the portion that mentioned Basic Security and thought why not. So I input a custom HTTP username and HTTP password and when I click to save this change it reloads the page asking for the username and password I had just entered. I type it in and then it just brings up the login page again blank as though I had input the information incorrectly. Now I don’t know whether I used characters that weren’t allowed, if it isn’t accepting the correct information, or if I typed in the password incorrectly and now I am unable to replicate that mistake.

Is there any way to reset this or will I need to make a new account?


#2

You can fix this by going to the config file and changing it. Its quite straightforward when you have access to the files.

You will need something like Notepad++ or some other code editor.
https://notepad-plus-plus.org/ download this free and really useful code editor.

Quit Sandbox.

Assuming Windows, go to C:\Users\Owner\AppData\Roaming\High Fidelity\domain-server\config.json.

Open the json.config in notepad++ and find the lines
"http_password": “c23ad6f18412014673b2d04794ca038ef6767fe94afe408dffb7753620000000”,
“http_username”: “adrian”,

Of course there will be your name and your encrypted password.

delete both lines entirely and save the file, then start Sandbox again.
Now refresh the settings page (http://localhost:40100/settings/)
and it should now show blank spaces for the HTTP username and HTTP password.

Put in your name and password as usual and save/restart. Should be good now.

Stick with letters and numbers both cases and normally accepted characters and refrain from using . (dot), comma, spaces, and slashes. (Underscore _ and dash - are acceptable in place of spaces or dots)


#3

Thank you kind sir! This worked like a charm.