Updating the High Fidelity Client Software is a Nightmare


#1

By far the most irritating thing about HiFi to me is the glitchy software update process. High Fidelity automatically installs its Sandbox software (to enable you to host your own content), plus nine assignment client processes in Windows, and these are all running continuously in the background, even if you are not using High Fidelity.

Every time I try to update the HiFi client software, I get en error message saying that proceses are running and I have to kill them first. I actually have to manually go in and kill each of the assignment client processes, and the Sandbox software, using the Windows Task Manager, before it lets me run the HiFi updater.

Ever try to kill all nine assignment client processes as they are continually respawning? It’s like trying to herd cats. This is a big, showstopper bug in my opinion. If I were a novice user that would completely throw me. I honestly cannot recommend HiFi to users unless they fix this really annoying problem with updating the client software.

Judas told me that it doesn’t happen to him though. I had assumed that everybody had this problem and they just put up with it. If there’s anything I can do to help you guys fix this, please let me know. I am willing to be a guinea pig :slight_smile:


#2

Hum… I simply do “Quit” in the HF icon menu in the windows tray bar to stop the server before run the install. That’s not too bad.

But if you setup a server to have HF server starting as a service, then yes… you need to kill all the processes… because there is no icon in the tray bar. That’s why I asked for Christmas a “Stop” button on the setting page.


#3

OK thanks! I didn’t even notice that there was an HiFi icon in the Windows tray bar until today. Thank you!

I will definitely try this before I attempt to do my next update. But I did tell the updater not to set up HiFi server starting as a server, and it did it anyways!


#4

You may need to uninstall sandbox directly before reinstalling the whole package to get the auto startup working right. For many users installing sandbox might not even be needed, only if you want to build stuff locally.


#5

You dont need to reinstall.
I had auto start disabled for a long time and a recent release (maybe this last one) has it starting itself without me selecting that, and I didnt know and had like 25 ACs running.
I only want to run sandbox when I need it and then shut it down after (on localhost).

I disabled auto start in Windows7.

Press Win-r . In the “Open:” field, type msconfig and press Enter .
Click the Startup tab.
Uncheck the items you do not want to launch on startup


#6

Thank you for the tip Adrian! I have now disabled my HiFi Sandbox processes which were always running in the background, even though I have nothing in my Sandbox and I don’t intend to use it.


#7

If this is true; choose ‘Advanced Installation’ during the next update and ONLY select Interface. I run Sandbox and Interface on different machines independently. No need to have one depend on the other. Give it a try.

:slight_smile:


#8

They have shifted the option at install to the custom settings. This now needs to be selected at each update install.
I discovered that auto start is the default setting if you use express install. Selecting Custom install allows you to uncheck the start on boot feature. But it needs to be specified every time.


#9

@Adrian

I’d like to find out if you’re running into a bug we haven’t seen yet.

Subsequent custom installs should maintain whatever checkboxes you picked the last time. If you do a default install in between two custom installs, the last custom install would show you the default options.

Do you remember if you did two custom installs back to back or if there was a default install in the middle?


#10

@Adrian

Additionally I am working on a change to auto select the install type you used last time (Custom/Express) so that it doesn’t keep defaulting to Express. This should let you hammer the next button and get the exact same options you had during your previous install.


#11

Sorry if you are asking me, I do not remember. But I chose to do a complete reinstall from scratch this time and I made sure not to install the Sandbox software.

But the latest version is buggy, I have posted a separate bug report to the Forums. You guys definitely broke something with this latest release!


#12

This is a good question, I only just found this on the last release so its actually the first time I selected it from the setup, both previous times I changed it thru windows start options. It is entirely possible that it works as it should, because I havent tried after setting the custom setting.


#13

After new installation, having selected to not start Sandbox in the advanced setup for the previous install. DOES indeed maintain this setting there after (at least the next install).
So @b this is not a but and working correctly.
Thank you.


Please no default startup sandbox
#14

@b
And the pendulum swings all the way back.

Yeah after having an episode of the sandbox loading itself, I checked advanced settings and said no startup please.

Ignore ignore ignore, and the sandbox starts all by itself, even after I have set the advanced settings to not start on bootup.

So it is a bug, was a bug whatever, is broken and wants to download the tutorial rubbish every time I start up.