Uploading Mesh to HIFI is an Information Nightmare


I am not the only person still struggling to see the creation in HIFI after uploading. I have tried, Google Drive, DopBox and my own FTP page to load URL’s in to the HIFI SandBox and I get nothing or just a box.
I talked to a Russian lady who talk me I have to use github to upload URLs of my mesh models.
From what I see of github it is only meant for uploading scripts. I do not see how I am supposed to upload my files on to github
The voice sever is forever distorting or cutting out key words when people talk in HIFI so it would be nice if someone kindly wrote the steps required to upload a mesh to HIFI.
I have been trying for months to figure out what I was doing wrong in Blender or changing sites to host my mesh and I am still not making progress.
Life is not so hard when I am not pondering on this problem.


I’m going to go grab a few forum links. Sit tight. I was once in your shoes too.


adding multiple hifi links is breaking my post… I’ll try to break them up…


First, a quick checklist so you are not insulted, and I do not waste your time.

  1. Make sure you are using the latest version of Blender 2.74
  2. If your mesh uses materials “PHONG” is currently best supported for HiFi import
  3. Check your .fbx export settings in Blender and make sure that you set them as a “pre-set” (i currently use 2 presets, 1 for avatars 1 for mesh items)
  4. I prefer to use my own domain http://captainoculus.com/ to host my .fbx while we are in Alpha stage. It is fast to use WinSCP to place my models there. If you use your own web domain you’ll need to access the .htaccess file to “open” read access to HiFi (link provided)
  5. NEVER assume (your methonds / or / HiFi) got it “right” the first time. The Interface updates frequently.
  6. Ensure you are running defaultScripts.js on initial load of Interface you can check this using (Ctrl+J) or (CMD+J) to quickly open “running scripts” panel. defaultScripts.js will have loaded multiple .js files on your behalf.
  7. Click the edit tool and then the upload tool and place your .fbx in the upload IF YOU ARE ATTEMPTING TO DO AVATARS IT IS .FST AND A FAR DIFFERENT PROCESS
  8. Allow HiFi to import your model then find it in the edit entities section and as a precaution be sure to hit “reset to original dimensions” I have to perform this task after each build of the London Eye. Strange… @chris @Adrian
  9. When all else fails, start tagging people to help you with your problem. @Judas may not be the village favorite; but he’s most definitely NOT the village idiot either. I nearly walked away from HiFi 1 month into my access until he helped me figure out .fbx import. Then Chris helped me troubleshoot warpcube2.fbx into my own Stack Manager.

One thing I’ve noticed so far within HiFi, if you are here as Alpha it is because you want HiFi to be successful. There are plenty of good people here (and foxes @Menithal) ready to spend time getting you the info you need. Take your time, and trust things will get resolved.

Links to come…


*** HTACCESS for domain hosts ***


*** Avatar Standards ***


*** Builders Diary ***



WRONG LINK (has since been edited in both places)
*** HTACCESS for domain hosts ***

Use this


Thanks dude. None of that actually answered my question about githud and URLS not working. Even if I do finally upload a mesh I can see in HIFI I will almost probably lose interest in the whole adventure. You did your best to help me with what works for you. Meanwhile I have all this software running on my computer and it is all pretty redundant.
I think it is time for me to step back and evaluate thinks. Probably remove a lot of redundant software and do something else.
Thanks again but as I say alot of the Export from Blender I already understand. I only wanted to understand what was going wrong with my uploading to HIFI.


Not a burden at all. Github? Not sure; I have no clue on that. If your mesh is invisible in HiFi make sure these are checked in Blender

  1. Apply Rotation and Scale and make sure your Blender units are Metric
  2. Use PHONG

Good luck!


Welcome to the Alpha,

Things are very rough around the edges and this unfortunately will cause you grey hair until it has left this phase of the development progress.
Because of the fact that we are in the middle of development progress, information out there can also get out-of-date quite quickly and things can change at a breakneck pace. I suggest just taking it in stride for now,

But do go through @Captain​.​​Oculus check list he posted in this thread: it tends to cover quite of the issues.

Here are some of my other notes:

  • Generally putting the models to your own server should work: just make sure you can access the model through http public url. (just copy and paste the link to your browser and see if it starts downloading) If it doesnt there is something wrong with the server you are hosting the files in.

  • I have documented all my findings on the Blender to FBX to FST notes at https://alphas.highfidelity.io/t/blender-compendium-and-woes-of-the-blender-fbx-export-at-the-mountains-of-documentation-madness/4739

  • And about the voice server, have you tried adjusting the buffer size higher or lower? It sounds like the default setting isn’t working for your connection, so you may have to play around with the values a bit (these actually need documentation I think)

I hope that helps.


I really have no clue what HTACCESS for domain hosts is or how hiding my model will make it visible.


Thanks I will try the downloading from URL to see is my models download. I am now wondering if I should be using Internet Explorer instead of FireFox. I will have a look at your documentation for any helpful clues.



It should be possible to download the model with any browser. (so firefox should be just fine)

The .htaccess file is a file used to define what files are public or not on an http service. its not really used for ftp servers. http://en.wikipedia.org/wiki/.htaccess

its can also used to limit the use of normal web browsers for downloading files…


AH! This could be why you are having trouble importing into HiFi. Ok, if you are using your own domain to host your .fbx files as you mention above, "my own FTP page to load URL’s " then what you need to do is enable the ability for other UserAgents (web developer term) to “see” the file. A server wont simply “serve” a file unless you allow it to.

The .htaccess file (stored on the domain) allows you to control this. See also directory browsing. You may not need to use the .htaccess file you could simply “allow all” browsing of the directory right from a browser (all agents - no read restrictions)

A great way to check that you have complied with this is to simply paste the link to your .fbx into a browser of your choice and if the server is in compliance it will “serve” you the .fbx as a download immediately. @chris explained that to @Foxxe I believe. Using the above .htaccess will enable HiFi UserAgents to “see” the .fbx but it will keep your directory locked from direct browsing.

Keep us posted.


Interestingly I uploaded a file that I could not see. Someone I was talking to did something to the file and then it was visible. Unfortunately the person could not explain to me what they had done because their sound kept cutting out. They kept crashing too.
The term htaccess Arrgh is giving me a headache sorry.
Uploading a URL for a model should be straight forward but learning how to is so disjointed because of the voice never working properly. This is a simple problem but is taking up miles and miles of text because of poor voice quality.


If you are using a mac, files starting with . are usually hidden by defualt (there is a way to unhide files).

On windows you can see all the hidden files in the folder, Tools > Folder options > View > Show Hidden files folders and drives.

In anycase, its a bit of getting used to, at this state it is actually quite multi-disciplinary, but once it keeps trucking along there will be services popping up that will manage these technical stuff for non-technies.

For now we have to teach and learn these things. But the voice issue seems to be bad, (the voice server is hosted in the domain you are connecting to) Have you tried playing around with the voice settings and increase / decreasing the voice buffer size? that may help.


I am talking about not visible in HiFI not on my computer


Ah, i misunderstood you, thought were talking about uploading the .htacess and not seeing it on your file system.

In anycase as captain stated, make sure that the model in question has a material.
That usually cause the model no be visible, or glitch out.


This is what I see on my FTP. When I put the models URL in to my FF browsers I am prompted for my password.
The folder named Public is a folder I made myself. I do not think it is working as a public folder in the FTP sense.
I can not download the file


I give up. Thanks for the help


Sorry to see you get frustrated by some of the techie talk.
Take a break and come back in a few weeks or months to try again.

We should have better tutorials by then.