Voxel Behaviour, Screen Refresh and Limits?


#1

I thought that the “sparse voxel octree” idea meant that if you placed a set of voxels together they would be combined into one larger one? So if you place four 1m cubes together to make a 2m x 2m x 1m shape is that still 4 separately refreshed voxels or one voxel?

I ask because I am seeing two separate problems…

ONE: I placed a flat plane on a 200m x 200m plot on the strip using the setGrass.js script from @KevinMThomas and that will place 200 x 200 x 1m voxels . I put another plane next to it, so that’s 200m x 200m x 2m and 40,000 drawn voxels, but ONE box shape. What seems to happen is that the two planes are drawn fine, but then about 40 rows (so about 8,000 of the last drawn voxels disappear after 20 seconds or so and always to exactly the same row that was last drawn. Also then if I add a voxel manually, it is drawn, but after a few seconds it disappears. Its as if a limit is set for how many voxels can be in the plot.

TWO: Although I have a very simple 2m deep green rectangle plane, when I move the avatar forward and then back, the edge of the block is redrawn quite slowly, I can see each 1m cube voxel being redrawn and it takes a few seconds. I am on a reasonably fast i7 processor Windows 8.1 system with a Nvidia GTX 680 GPU. No shadows are turned on (as that sometimes causes the voxels to not be displayed due to another reported issue).



#2

In my experience everything seems to get built twice, the build (any build) quickly puts down the voxels as if in the local view only, then begins to add them to the server and you see them being replaced at a much slower rate, but they will finish.
(watch the stats, server voxels increase as the script is running)

If you wait till this has completed (a minute or so) then the next script is quite quick, but if you start the next script before the first script has completed (as in the server voxel count settles and stops ticking over) then everything slows down. like trying to start a second download while there is already a download happening. Probably has to do with thread sharing or something.

I have experienced a time when I tried to build a floor on the strip and for some reason it seemed to stop 3/4 way thru, every time at pretty close to the same place, I put it down to a bad server day, but I havent tried to run a script in @alpha since the strip was invaded with massive voxels. I’m sure @chris will clear the strip when he gets back from hols.