Voxels. it's good but still problems


#1

Ok, played a bit with voxels. pplacing works. offcorse it’s torture for your mouse finger :open_mouth:

  • It seems there’s no unde right now
  • You cannot disable voxel edit so it’s possible to move the voxel. Now
    you only make changes you cannot undo.
  • I don’t see how i can change textures right now except i see option
    for only X,Y,Z

Well, it’s looking good and still in development, at soem point i expect we get the paint brush back and option to smooth the terrain. and the other problems are solved then aslo


#2

There’s are some confusing icons.

Icon Nr.1 is placing a voxelbox.
My suggestion would be to open with icon Nr.1 the voxels.js script. or remove the voxel icon from the edit bar.
Place at the same time Icon Nr.1 in the voxels.js script and use that button to draw a voxel box or Terrain.box

Mabye some icon images need to be updated or changed.
Other thing i just noticed, stopping the voxels.js script did not removed the icons from screen. (build 3097

ADD: Other question, i like to edit voxels. but i want to disable edit. so the voxel box is not moving when you edit. But at the moment you disable edit you not have any good camera view anymore. and ALT works. For terrain you anyway need a bigger zoom distance what seems to fail with edit camera. besides i cannot make the correct camera postion like you can in secondlife. the edit camera is to restricted in movement.


#3

Noticed a new weird problem with voxel terrain. when you place the terrain box. some sides don’t have textures.

It’s at this point also really hard to see what you are doing, it’s more gambling what’s going to happen and where. Hard to make tiny changes , so you can have a ramp or something like that to get somewhere without jumping.

Puncingf a hole in front of me with sphere seems impossible. cube mode let me do the digging for the tunnel. Also with a box you need to make sure your pretty close to the avatar. if your outside the tunnel with the camare a little bit it’s failing to delete a part.

Sad news, there’s no light at the end of the tunnel ! :smile:

But i made a tunnel, jumping is not working very good right now. because the edges are to high. Also i wish mouselook worked without holding the right mouse button.


#4

Does the terrain box have an option for a heightmap .RAW data?


#5

It’s still in very basic state. not found it. also the need to add and improve things on it. But wanted todo soemthing until other things are fixt for me.


#6

When you cannot click the voxels or they do not respond you need to go back and click from a further distance, this appears to work. You can use several edit modes which you can set in the Entity Tool window.


#7

For me it’s the opposite. when i want to edit the voxels like digging a tunnel i need to get closer with my camera. You don’t need to have the voxel object selected. It;s better if it’s not selected when you edit. or you move the whole terrain, when you edit the terrain.