VR Mode broken after 2663 (on pre-Kepler GPUs)


#1

Somewhere after build 2663 but at or before 2669, VR mode was broken. Entering VR mode stalls all rendering. The lovely software cursor also freezes. I can exit VR mode and interface resumes rendering. This is with an Oculus DK2. The current release, 2672, also has a broken VR mode.


#2

The VR code is undergoing a bit of work. Two of the main changes that happened recently were that we moved to the Oculus 0.6 SDK (on windows only) and we are no longer using the main application window as the rendering output for VR.

On OSX and Linux we create a new dedicated window for VR output and place it on the Rift display. This window continues to receive updates, but the primary window does not, hence it looks like rendering is completely frozen on the main window. Eventually that should be fixed by having the main window contain something that says the VR display is active and lets the user turn on or off mirroring to the main window. Right now mirroring is disabled because of performance issues.

On Windows, with the new SDK, the application is no longer responsible at all for creating a Rift display window. Instead the VR SDK / Runtime handles it. Again, the upshot of this is that we’re not updating the primary window so it will appear frozen.

The rendering should continue inside the headset. However, you need to make sure you have the latest version of the Oculus runtime (0.6.x) in order for it to work on Windows.

Additionally, recent rendering pipeline changes have broken all the overlays while in VR mode, but I’m working on fixing that as well.


#3

I am running with the 0.6.0.0 beta runtime. I’ll rummage about to see if this is a configuration changed now that it runs in extended mode.


The DK2 is in direct mode, which is how it worked with the older interface versions. I switched it to extended display mode, and that shows the desktop in the DK2. Going into VR mode is not rendering on that screen.

Now the Oculus is working in HMD mode in the sense that if I rotate it then leave HMD mode the scene camera has moved. So, it is that interface is not talking to the DK2’s driver?

This is an ASUS g73 running Windows 7 ultimate.


#4

Alright, I completely uninstalled and reinstalled the Oculus v0.6.0.0 beta runtime. After a number of system restarts to get new bits, no joy. Entering VR mode, I see the tracker LED light up, but the screen does not light up nor does the LED on the DK2 switch to active mode (blue).

Is this working for you?

That was two hour’s worth of unfruitful testing.


#5

Yes, although I’m running on a desktop, not a laptop, and I’m running Windows 8.1.

Can I assume that other Rift apps function (like the demo scene in the config util)? Have you been able to get it to work in Extended mode? I wasn’t clear from how you worded the post.


#6

Trying to help.

Rift Mode “works” for me, however no geometry is rendered.

Interface 2678
Windows 7 Pro SP1 x64
DK2 - 0.6 win beta runtime
Dell 21:9 2560x1080 monitor


#7

There is a mob with tar and pitchforks over at the oculus forums about this problem: See forums - click here and it looks like a bug in the 0.6.0.0 runtime that affects some machines. My ASUS meets all the prerequisites (latest platform update from Microsoft, runs DX11, has DX11 compatible graphics hardware, does not have Optimus graphics switching whizdang, etc.). This is happening on some desktop systems as well, so expect people to complain here. Hopefully Oculus devs will fix their code, or, HF devs can find a workaround.

And, the config demo screen does not work - all black.

So, I am boxing up my DK2 for the duration - oh well.


#8

Switching to extended mode lights up the DK2. I see the desktop. Can move windows to the extended desktop which are seen in the DK2, not particularly useful, but a decent diagnostic.

The demo scene from the config util yields a black window in both direct and extended modes.

The latest interface app only works in direct mode, so it will not work in extended mode.

I am presently going to the painfully long process of rolling back graphics drivers to see if that is implicated. There is order dependency so I have to uninstall the OVR runtime, restart, rollback the driver, reinstall the runtime, restart. So far rolled back from may to march, no changes.

[edit]
Driver rollbacks did not help
It does look like the OVR runtime 0.6.0.0 just has a bug.


#9

If you can’t get the demo scene running, then the problem is outside the scope of what we can do. Unfortunately Oculus’ latest SDK isn’t functional across all hardware configurations. If you’re using a laptop with Optimus display tech in particular, it’s likely to not work.

Actually, the latest SDK from Oculus removes the distinction between extended and direct mode, from the point of view of the application. Interface should work in both on supported hardware.

We’re currently working on a display plugin mechanism in order to support OpenVR for Vive, OSVR for Razer’s headset, etc… once that’s done you may be able to get the app working again with your hardware by using the OpenVR plugin. Additionally, we may have an Oculus 0.5 SDK and an Oculus 0.6 SDK plugin, so that user’s running the older runtime for compatibility will be able to function.


#10

Yes, I am familiar with the compositor process in the 0.6.xx release, and NO, this ASUS does not have the Optimus cruft, solely the GTX460. Like I said a number of responses earlier, it is clearly an Oculus runtime bug. It is happening to people with desktop systems too. I was going through the long steps to see if the problem was related to driver versions, so after several rollbacks it became all to clear Oculus has blown the runtime. There are scores of people complaining on their forums already about this.

Agreed it is likely outside your scope, though who knows workarounds might exist (one can only hope)…

Anyway, I’ve spent too much time trying to get the Oculus to work on HF’s interface. It worked nicely briefly before you switched to the 0.6.0 APIs. Understandable why you did. It’s not a deal breaker for me to not have VR experience with HF for the moment. Maybe when I get my 980 based system I’ll come back to it.


#11

The Oculus 0.6.0.1 runtime and SDK are now available. Their release notes finally spell out the hardware problem. Most if any pre-Kepler architecture GPUs will not work with the runtime in direct mode. That knocks out a lot of machines over two years old. Only Kepler or Maxwell architectures work.


http://www.geforce.com/landing-page/graphics-cards-with-kepler-architecture

I just boxed up and shelved my DK2 until I end up getting a new computer, probably next year when production ready VR gear arrives.