WEB entities missing sound


Make a WEB entity. Set it’s URL to either:

Try to play music on those WEB sites. Do you hear the content?


Might be by design due to attenuation, it would be too awesome!


Tried it, first problem where that i needed to check if i did it correct inworld. and high fidelity is still stealing the audio output device and set it to the wrong on in desktop mode. So annoying that bug. Since the HTC vive audio get to many times hijacked and routed to the HTC vive. :rage: while am not in vive mode ! also steam is not running.

But back to the problem, i can only trfy https://soundcloud.com and that is just not playing at all, inworld you can click the play button. butr then nothing happens. compared it to a normal webbrowser. Looks for me some script or function is not executed inside high fidelity.

I tried one of my you tube video’s https://www.youtube.com/watch?v=jWp7siAPeuc and that play fine with sound. The https://soundcloud.com webpage is not compatible with high fidelity.


The http://magnatune.com site used to work quite nicely for me since the day I joined the alpha program. About a dozen dev releases ago (maybe more), it stopped working. And now, any time I interact with either magnatune or sound cloud, interface app crashes when I attempt to quit the app.


Aha, that explane the crash. Linked it to the web entity anyway.


Yes, a simple youtube vid does play sound.

Apparently soundcloud and magnatune, both sites where I pay for a license to stream is not available to me in HF.


we don’t support flash, its proprietary, which seems to be why soundcloud doesn’t work…?


Soundcloud works without flash. It can run in html5 mode. I have removed flash from my system (yes, including the rogue copies found in the Edge browser).


welp that’s a screenshot from the browser in interface, with soundcloud trying to do flash. do you have a url or some other flag to view soundcloud in HTML5 mode? or know if its based on a certain user agent string or something? we identify as “Mozilla/5.0 Chrome/38.0 (HighFidelityInterface)”, but that can be adjusted.

also what does your ‘magnatune’ site use for its media player?


there is a known issue with sound not coming thru the right device on web entities when you’re wearing an HMD, but i think your issue is something else… we will figure it out :slight_smile:


NOTE: I’ll repeat what I wrote earlier. This used to work in WEB entities months ago. Now it does not. Actually about a dozen dev releases ago of interface app it stopped working. I reported it right away, and it got overlooked or ignored.

Soundcloud autosenses flash availability and switches to HTML5.

Here’s a direct link to a track. It plays OK on my system which has flash uninstalled:

Here is another example of autosensing flash is missing that works. In this example, you will briefly see the flash is not there message, then it switches to an html5 version. This example behaves the same on my flash-less system as well as in a WEB entity:

Were I to guess, I think the user agent string makes soundcloud and magnatune believe there is no html5 support, so lacking flash it goes no further.

I’d have to dig through the javasript to find which player magnatune uses. You can probably do a quicker job on that rock fetch. :slight_smile:


Not using HMD. This is desktop mode.


BTW, the WEB entity related crash-on-quit seems to only happen if you click on and interact with a WEB entity. The crash-on-quit does not happen if you happen to be in a place with a WEB entity active.


so i dug deeper and think i know what’s up.

it’s not the userAgent – i tried many of them and none worked. Other HTML5 features work properly, which led me to discover that the version of chromium that we compile with QTWebengine doesn’t support .mp3 by default because its a proprietary codec. you can compile interface with .mp3 support, but we can’t distribute that.

so when soundcloud looks to see whether it should serve flash or html5, it must do it based on the ability to play .mp3 files. our browser cannot play .mp3, so soundcloud tries to serve the flash.

in summary. you could build your own interface that works with soundcloud if its important to you. beauty of open source. but its not likely to make it into the main branch because its proprietary. i wish that the state of things were different, and everyone had a nice high quality open codec that the music was actually in!


p.s. here’s the post on what flag to enable

more info on codecs

Remove the backspace delete from the edit tools. (we have delete key !) and give better feedback what is selected

Thank you for your explanation. Most of the mp3 patents have expired, so what you wrote does not make sense. There is the Fraunhofer-Gesellschaft patent that expires Dec 2017, but that patent is about some of the extra encoding extensions of MP3

In any case, telling me to go write some code and basically make a version of interface that I’d have to keep updating manually upon every release is a nice way of telling to get lost, and I guess I’ll have to, especially with other bugs preventing me from doing much here.

I can’t imagine how a major developer interested in HF would respond to that one.

Time for another break from HF. Catch you all in September!