Why can we not set different X,Y,Z dimension on spotlight?


#1

I wanted to try something. The spotlight where 9,9,9 in dimension.
I tried to scale the Y dimension. but that also change the other dimensions and you have a big light again.

Why canw e not set the sizes seperate ?
Especialy with spotlights it sounds usefull if we can change (X+Z) and Y seperate in size.


#2

@Richardus.Raymaker, what you are seeing is another one of those broken UI problems with edit.js first, a light source is always spherical, so all the dimensions must be the same. Using the default and broken editor, you can increase any of the X/Y/Z dimensions, either using the up arrow or typing in a larger value, on a light source and it will set the other dimensions to the new value. However, decreasing the values has broken logic and edit refuses to make it smaller.

This is one of those priority -83753 issues so I wouldn’t make plans. For now the easiest way to work with it is to click on the “Reset Dimensions” button. That will set the light to 1m. Then you can enter any value greater than 1m. The editing corners work too though they tend to be twitchy.

For spotlighting, there are options to do that. Scroll to the bottom of the entity editor. There you can set falloff and angles.


#3

I have never seen prblems with make it bigger or smaller.
I have problems with making a small spotlight without a hugh box around it.
It’s impossible to set in spotlight mode something like 1,10,1 meter
all numbers are set to the same size 1 or 10 meter.


#4

I tested it. It works incorrectly as I described. This is with the latest beta release. And setting 1,10,1 is very easy. you click on the [x] spotlight setting then change the angle to around 8 degrees.


#5

Oh, it’s btw named spotlight cut-off possible the reason why i never seen or did understand it. wrong naming. you talked about angle, what let em already up to a hunt for finding it.

Btw, the still have after around 1 year now still not fixt the problem with selecting spotlights. It’s a crime. yoiiu select it in the entities list. then you need to select it inworld !, to start using F-key function. You only cannot select it inworld. unless you figured out to select the up/down arrow. I hope that the go rewite edit.js after the tablet implementation. (because i guess the put it in there)

Anyway thanks, that makes a whole difference