Why does one object always load really slowly?


#1

I have a building that is reasonably heavy but not the heaviest.
It quite often just refuses to show, even though it should be in the cache.
I go to the location and everything else shows, and this tower wont show and doesnt appear in the entities list and no errors are shown.
It is quite tall and sometimes I used to have to fly back and up and give the whole thing enough space on the screen to show, this used to work but now nothing, like its gone.
I TP away and back still gone, I log out and back, still gone.
I go to load a fresh one because I am convinced its been lost somewhere, and suddenly I have 2 of these towers.

The first one only appears after I have imported another one.

Expected behaviour:
Stuff should show. I shouldnt have to shuffle around and pan out to make the scene load, it should just load what I am looking at.

Anyone else seeing this? have any suggestions?
thanks.


#2

ATP or HTTP ? and what is the location to check ?


#3

Its HTTP, the location is Venice and the building is the Campanile bell tower.
It should be right in front of you when you land in Venice, it has a gold statue of Gabriel on the top, if the statue is missing you will still see the statue in the air at about 300M straight up.


#4

Got it. i did not moved. only looked around. But i see the tower. I guess it where not cached for me. Build 4864

Add: It’s not loading when i do second visit. I see error too.
[05/13 15:28:26] [WARNING] libpng warning: iCCP: profile ‘ICC profile’: ‘CMYK’: invalid ICC profile color space.
Aha !, the tower appears when i look up. looks like the same bug as with shadows. if it’s out of view range. it’s disappearing.

Teleporting out and back in while am still looking up. Then the building is laoding almost as first. Sounds like not in view range problem.

Nice , lot’s builded there. especially compared to mine.


#5

Damn right I am. I’ve had 3 instances of the Alpha Quintessance due to this exact problem. I hope they can root it.

Also, if I’ve got my boat (The Alpha Quintessance) in cache, and it’s across the room on a HDD, shouldn’t my machine get priority? It is after all on a Gigabit LAN…

Curious about the responses to this…


#6

@Adrian I went there and managed to repro. It’s not a problem with the cache, but with he algorithm that sends you the entity tree infos.
It’s very tall and high, and the entity server must be messing up and not realize it’s in you field of view, so it doesn’t send it to you (ie. the entity infos).

So your client doesn’t even know it’s there, you can just look up and the building will show.
I’m filling a bug, thanks for the heads up! (Got it? Come on, I’m proud of this one!)


#7

Good one Clement.
Richardus pointed out that the center of the object needs to be in view for the object to render, which is why an object 12K away will render but an object 50M up wont.
This tower is 100m high which puts the center of the object at 50m.

I thought of a workaround, take the tower into blender and add a 100m cube to the bottom of it and make this cube invisible, This would have the effect of setting the center of the tower at ground level, with 100m up and 100m down.


#8

Actually, the bounding box just need to intersect with your view frustum.
Same for the entity server to decide to send it to you. Since it didn’t show up in my entity list until I looked up, that means the server is not honoring that “If the bounding box clips into my frustum, send me the data” rule for some reason.
Once it loaded, you’ll see the building without looking up, so that confirms it’s the server and not the rendering.

It the mean time, you should try to lower the registration point of the entity, so that the center of the entity is lower. This way if it’s a bounding box scaling issue or something of the like, it should work.


#9

I had thought of the registration point but hadnt tried it.
I have lowered the registration point to zero on the Y axis.
First pass at going away and coming back seems to have worked, I will continue the testing but this is a much easier fix.
Thank you.


#10

Adrian, would you chat with me on gitter (@sethalves) or send me an email at seth@highfidelity.io – I could use some help figuring this one out.


#11

Sure, however I am in a different timezone so I am not sure when you will get the reply.
The moving of the registration point seemed to have solved this I think.
I have opened gitter anyway.